summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRuben Kerkhof <ruben@rubenkerkhof.com>2020-01-20 13:58:11 +0100
committerDarren Tucker <dtucker@dtucker.net>2020-01-21 10:46:11 +1100
commit0c428c0e991e2c4fabc48cf5d9b8f84c9412e0c3 (patch)
treea16ed6ded04d0fe51346424c5378c60fb7f1b1ee /configure.ac
parent6089abf715e2784751c9f62697e09bb103295b93 (diff)
configure.ac: fix ldns test
When running ./configure --with-ldns, if ldns-config cannot be found, we add -Iyes/include to CPPFLAGS and -Lyes/lib to LDFLAGS. Fix that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b1b3bdacf..85e687773 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1533,8 +1533,6 @@ AC_ARG_WITH(ldns,
1533 if test "x$withval" = "xyes" ; then 1533 if test "x$withval" = "xyes" ; then
1534 AC_PATH_TOOL([LDNSCONFIG], [ldns-config], [no]) 1534 AC_PATH_TOOL([LDNSCONFIG], [ldns-config], [no])
1535 if test "x$LDNSCONFIG" = "xno"; then 1535 if test "x$LDNSCONFIG" = "xno"; then
1536 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1537 LDFLAGS="$LDFLAGS -L${withval}/lib"
1538 LIBS="-lldns $LIBS" 1536 LIBS="-lldns $LIBS"
1539 ldns=yes 1537 ldns=yes
1540 else 1538 else