summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2019-07-23 21:51:22 +1000
committerDarren Tucker <dtucker@dtucker.net>2019-07-23 22:06:24 +1000
commit11cba2a4523fda447e2554ea457484655bedc831 (patch)
tree93ec07a9e0db784b0a729eb339d74a5a2c40ea9d /configure.ac
parent09159594a3bbd363429ee6fafde57ce77986dd7c (diff)
Re-apply portability changes to current sha2.{c,h}.
Rather than attempt to apply 14 years' worth of changes to OpenBSD's sha2 I imported the current versions directly then re-applied the portability changes. This also allowed re-syncing digest-libc.c against upstream.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 6 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 63e017733..1c35b090b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1699,6 +1699,9 @@ AC_CHECK_FUNCS([ \
1699 Blowfish_expandstate \ 1699 Blowfish_expandstate \
1700 Blowfish_expand0state \ 1700 Blowfish_expand0state \
1701 Blowfish_stream2word \ 1701 Blowfish_stream2word \
1702 SHA256Update \
1703 SHA384Update \
1704 SHA512Update \
1702 asprintf \ 1705 asprintf \
1703 b64_ntop \ 1706 b64_ntop \
1704 __b64_ntop \ 1707 __b64_ntop \
@@ -2849,16 +2852,9 @@ if test "x$openssl" = "xyes" ; then
2849 fi 2852 fi
2850 AC_CHECK_FUNCS([crypt DES_crypt]) 2853 AC_CHECK_FUNCS([crypt DES_crypt])
2851 2854
2852 # Search for SHA256 support in libc and/or OpenSSL 2855 # Check for SHA256, SHA384 and SHA512 support in OpenSSL
2853 AC_CHECK_FUNCS([SHA256_Update EVP_sha256], , 2856 AC_CHECK_FUNCS([EVP_sha256 EVP_sha384 EVP_sha512])
2854 [unsupported_algorithms="$unsupported_algorithms \ 2857
2855 hmac-sha2-256 \
2856 hmac-sha2-512 \
2857 diffie-hellman-group-exchange-sha256 \
2858 hmac-sha2-256-etm@openssh.com \
2859 hmac-sha2-512-etm@openssh.com"
2860 ]
2861 )
2862 # Search for RIPE-MD support in OpenSSL 2858 # Search for RIPE-MD support in OpenSSL
2863 AC_CHECK_FUNCS([EVP_ripemd160], , 2859 AC_CHECK_FUNCS([EVP_ripemd160], ,
2864 [unsupported_algorithms="$unsupported_algorithms \ 2860 [unsupported_algorithms="$unsupported_algorithms \