diff options
author | Darren Tucker <dtucker@zip.com.au> | 2005-12-19 17:40:40 +1100 |
---|---|---|
committer | Darren Tucker <dtucker@zip.com.au> | 2005-12-19 17:40:40 +1100 |
commit | 129d0bb6a65dcd9639e841cc3fd2ef3490420d7b (patch) | |
tree | a56f568a753739143c8662390e8cf6d8f2f34025 /configure.ac | |
parent | d40c66cf3f5d7713ea9489778dc450a48984a81d (diff) |
- (dtucker) [cipher-aes.c cipher-ctr.c cipher.c configure.ac
openbsd-compat/openssl-compat.h] Check for and work around broken AES
ciphers >128bit on (some) Solaris 10 systems. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 20 |
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index df85e319f..9325c4364 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.315 2005/12/17 11:32:03 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.316 2005/12/19 06:40:40 dtucker Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -1803,6 +1803,24 @@ Also see contrib/findssl.sh for help identifying header/library mismatches.]) | |||
1803 | ] | 1803 | ] |
1804 | ) | 1804 | ) |
1805 | 1805 | ||
1806 | # Check for OpenSSL without EVP_aes_{192,256}_cbc | ||
1807 | AC_MSG_CHECKING([whether OpenSSL has crippled AES support]) | ||
1808 | AC_COMPILE_IFELSE( | ||
1809 | [AC_LANG_SOURCE([[ | ||
1810 | #include <string.h> | ||
1811 | #include <openssl/evp.h> | ||
1812 | int main(void) { exit(EVP_aes_192_cbc() == NULL || EVP_aes_256_cbc() == NULL)} | ||
1813 | ]])], | ||
1814 | [ | ||
1815 | AC_MSG_RESULT(no) | ||
1816 | ], | ||
1817 | [ | ||
1818 | AC_MSG_RESULT(yes) | ||
1819 | AC_DEFINE(OPENSSL_LOBOTOMISED_AES, 1, | ||
1820 | [libcrypto is missing AES 192 and 256 bit functions]) | ||
1821 | ] | ||
1822 | ) | ||
1823 | |||
1806 | # Some systems want crypt() from libcrypt, *not* the version in OpenSSL, | 1824 | # Some systems want crypt() from libcrypt, *not* the version in OpenSSL, |
1807 | # because the system crypt() is more featureful. | 1825 | # because the system crypt() is more featureful. |
1808 | if test "x$check_for_libcrypt_before" = "x1"; then | 1826 | if test "x$check_for_libcrypt_before" = "x1"; then |