diff options
author | Darren Tucker <dtucker@dtucker.net> | 2018-10-16 14:45:57 +1100 |
---|---|---|
committer | Darren Tucker <dtucker@dtucker.net> | 2018-10-16 14:45:57 +1100 |
commit | 1673274aee67ce0eb6f00578b6f3d2bcbd58f937 (patch) | |
tree | 2e893928cc16cdc5b8fdb58034416ef751307bf9 /configure.ac | |
parent | 4e23deefd7959ef83c73ed9cce574423438f6133 (diff) |
Remove gcc spectre mitigation flags.
Current impementions of the gcc spectre mitigation flags cause
miscompilations when combined with other flags and do not provide much
protection. Found by fweimer at redhat.com, ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 9 |
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac index 9dacccb2d..099ecdaa9 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -164,15 +164,6 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then | |||
164 | OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result]) | 164 | OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result]) |
165 | OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing]) | 165 | OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing]) |
166 | if test "x$use_toolchain_hardening" = "x1"; then | 166 | if test "x$use_toolchain_hardening" = "x1"; then |
167 | # Cygwin GCC 7.x allows thunking on the CLI, but produces non-working | ||
168 | # code. Unfortunately you only notice this at link time. | ||
169 | case "$host" in | ||
170 | *-*-cygwin*) ;; | ||
171 | *) | ||
172 | OSSH_CHECK_CFLAG_COMPILE([-mfunction-return=thunk]) # gcc | ||
173 | OSSH_CHECK_CFLAG_COMPILE([-mindirect-branch=thunk]) # gcc | ||
174 | ;; | ||
175 | esac | ||
176 | OSSH_CHECK_CFLAG_COMPILE([-mretpoline]) # clang | 167 | OSSH_CHECK_CFLAG_COMPILE([-mretpoline]) # clang |
177 | OSSH_CHECK_LDFLAG_LINK([-Wl,-z,retpolineplt]) | 168 | OSSH_CHECK_LDFLAG_LINK([-Wl,-z,retpolineplt]) |
178 | OSSH_CHECK_CFLAG_COMPILE([-D_FORTIFY_SOURCE=2]) | 169 | OSSH_CHECK_CFLAG_COMPILE([-D_FORTIFY_SOURCE=2]) |