summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-03-25 18:26:01 +1000
committerDarren Tucker <dtucker@zip.com.au>2007-03-25 18:26:01 +1000
commit20e9f976c16f98f3106f2dc298421a4a8c1ca8d7 (patch)
treeacc6ed43d91699d7a670eb91d13bedd3147a7c71 /configure.ac
parent9869ab35577fdeafecdff2bec00036408d576f0e (diff)
- (dtucker) [Makefile.in configure.ac] Replace single-purpose LIBSELINUX,
LIBWRAP and LIBPAM variables in Makefile with the general-purpose SSHDLIBS. "I like" djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 12 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index f155ada60..a2a988c7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.373 2007/03/21 10:39:57 dtucker Exp $ 1# $Id: configure.ac,v 1.374 2007/03/25 08:26:01 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.373 $) 18AC_REVISION($Revision: 1.374 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1109,8 +1109,7 @@ AC_ARG_WITH(tcp-wrappers,
1109 CPPFLAGS="-I${withval} ${CPPFLAGS}" 1109 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1110 fi 1110 fi
1111 fi 1111 fi
1112 LIBWRAP="-lwrap" 1112 LIBS="-lwrap $LIBS"
1113 LIBS="$LIBWRAP $LIBS"
1114 AC_MSG_CHECKING(for libwrap) 1113 AC_MSG_CHECKING(for libwrap)
1115 AC_TRY_LINK( 1114 AC_TRY_LINK(
1116 [ 1115 [
@@ -1126,7 +1125,7 @@ AC_ARG_WITH(tcp-wrappers,
1126 AC_DEFINE(LIBWRAP, 1, 1125 AC_DEFINE(LIBWRAP, 1,
1127 [Define if you want 1126 [Define if you want
1128 TCP Wrappers support]) 1127 TCP Wrappers support])
1129 AC_SUBST(LIBWRAP) 1128 SSHDLIBS="$SSHDLIBS -lwrap"
1130 TCPW_MSG="yes" 1129 TCPW_MSG="yes"
1131 ], 1130 ],
1132 [ 1131 [
@@ -2028,7 +2027,7 @@ AC_ARG_WITH(pam,
2028 2027
2029 PAM_MSG="yes" 2028 PAM_MSG="yes"
2030 2029
2031 LIBPAM="-lpam" 2030 SSHDLIBS="$SSHDLIBS -lpam"
2032 AC_DEFINE(USE_PAM, 1, 2031 AC_DEFINE(USE_PAM, 1,
2033 [Define if you want to enable PAM support]) 2032 [Define if you want to enable PAM support])
2034 2033
@@ -2038,11 +2037,10 @@ AC_ARG_WITH(pam,
2038 # libdl already in LIBS 2037 # libdl already in LIBS
2039 ;; 2038 ;;
2040 *) 2039 *)
2041 LIBPAM="$LIBPAM -ldl" 2040 SSHDLIBS="$SSHDLIBS -ldl"
2042 ;; 2041 ;;
2043 esac 2042 esac
2044 fi 2043 fi
2045 AC_SUBST(LIBPAM)
2046 fi 2044 fi
2047 ] 2045 ]
2048) 2046)
@@ -3157,19 +3155,18 @@ LIBSELINUX=""
3157AC_ARG_WITH(selinux, 3155AC_ARG_WITH(selinux,
3158 [ --with-selinux Enable SELinux support], 3156 [ --with-selinux Enable SELinux support],
3159 [ if test "x$withval" != "xno" ; then 3157 [ if test "x$withval" != "xno" ; then
3158 save_LIBS="$LIBS"
3160 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) 3159 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
3161 SELINUX_MSG="yes" 3160 SELINUX_MSG="yes"
3162 AC_CHECK_HEADER([selinux/selinux.h], , 3161 AC_CHECK_HEADER([selinux/selinux.h], ,
3163 AC_MSG_ERROR(SELinux support requires selinux.h header)) 3162 AC_MSG_ERROR(SELinux support requires selinux.h header))
3164 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], 3163 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
3165 AC_MSG_ERROR(SELinux support requires libselinux library)) 3164 AC_MSG_ERROR(SELinux support requires libselinux library))
3166 save_LIBS="$LIBS" 3165 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
3167 LIBS="$LIBS $LIBSELINUX"
3168 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) 3166 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3169 LIBS="$save_LIBS" 3167 LIBS="$save_LIBS"
3170 fi ] 3168 fi ]
3171) 3169)
3172AC_SUBST(LIBSELINUX)
3173 3170
3174# Check whether user wants Kerberos 5 support 3171# Check whether user wants Kerberos 5 support
3175KRB5_MSG="no" 3172KRB5_MSG="no"
@@ -4005,7 +4002,10 @@ echo " Compiler: ${CC}"
4005echo " Compiler flags: ${CFLAGS}" 4002echo " Compiler flags: ${CFLAGS}"
4006echo "Preprocessor flags: ${CPPFLAGS}" 4003echo "Preprocessor flags: ${CPPFLAGS}"
4007echo " Linker flags: ${LDFLAGS}" 4004echo " Linker flags: ${LDFLAGS}"
4008echo " Libraries: ${LIBWRAP} ${LIBPAM} ${LIBS}" 4005echo " Libraries: ${LIBS}"
4006if test ! -z "${SSHDLIBS}"; then
4007echo " +for sshd: ${SSHDLIBS}"
4008fi
4009 4009
4010echo "" 4010echo ""
4011 4011