summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2014-08-20 11:05:03 +1000
committerDamien Miller <djm@mindrot.org>2014-08-20 11:05:03 +1000
commit2195847e503a382f83ee969b0a8bd3dfe0e55c18 (patch)
tree910a4269a0f34a711a3c89376616b6cb8c6f2677 /configure.ac
parenta75aca1bbc989aa9f8b1b08489d37855f3d24d1a (diff)
- (djm) [configure.ac] Check OpenSSL version is supported at configure time;
suggested by Kevin Brott
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 866acc8a6..11e8e12e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.578 2014/07/15 00:41:39 djm Exp $ 1# $Id: configure.ac,v 1.579 2014/08/20 01:05:03 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.578 $) 18AC_REVISION($Revision: 1.579 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2278,13 +2278,21 @@ AC_RUN_IFELSE(
2278 if(fd == NULL) 2278 if(fd == NULL)
2279 exit(1); 2279 exit(1);
2280 2280
2281 if ((rc = fprintf(fd ,"%x (%s)\n", SSLeay(), SSLeay_version(SSLEAY_VERSION))) <0) 2281 if ((rc = fprintf(fd ,"%x (%s)\n", SSLeay(),
2282 SSLeay_version(SSLEAY_VERSION))) <0)
2282 exit(1); 2283 exit(1);
2283 2284
2284 exit(0); 2285 exit(0);
2285 ]])], 2286 ]])],
2286 [ 2287 [
2287 ssl_library_ver=`cat conftest.ssllibver` 2288 ssl_library_ver=`cat conftest.ssllibver`
2289 # Check version is supported.
2290 case "$ssl_library_ver" in
2291 0090[0-7]*|009080[0-5]*)
2292 AC_MSG_ERROR([OpenSSL >= 0.9.8f required])
2293 ;;
2294 *) ;;
2295 esac
2288 AC_MSG_RESULT([$ssl_library_ver]) 2296 AC_MSG_RESULT([$ssl_library_ver])
2289 ], 2297 ],
2290 [ 2298 [