summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2006-07-12 14:14:31 +1000
committerDarren Tucker <dtucker@zip.com.au>2006-07-12 14:14:31 +1000
commit248469bc8d6c001596fdd3a83c1ffc63ae466e5b (patch)
tree9bb895755ccbdd68742c3f96950ce07efbb7850c /configure.ac
parente0e4aad1fdd8770283798eede1297f363b43498d (diff)
- (dtucker) [configure.ac defines.h] Only define SHUT_RD (and friends) and O_NONBLOCK
if they're really needed. Fixes build errors on HP-UX, old Linuxes and probably more.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c6d56bf4a..19446b3bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.345 2006/07/11 08:00:06 dtucker Exp $ 1# $Id: configure.ac,v 1.346 2006/07/12 04:14:31 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.345 $) 18AC_REVISION($Revision: 1.346 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1285,6 +1285,19 @@ AC_CHECK_DECL(tcsendbreak,
1285 1285
1286AC_CHECK_DECLS(h_errno, , ,[#include <netdb.h>]) 1286AC_CHECK_DECLS(h_errno, , ,[#include <netdb.h>])
1287 1287
1288AC_CHECK_DECLS(SHUT_RD, , ,[#include <sys/socket.h>])
1289
1290AC_CHECK_DECLS(O_NONBLOCK, , ,
1291 [
1292#include <sys/types.h>
1293#ifdef HAVE_SYS_STAT_H
1294# include <sys/stat.h>
1295#endif
1296#ifdef HAVE_FCNTL_H
1297# include <fcntl.h>
1298#endif
1299 ])
1300
1288AC_CHECK_FUNCS(setresuid, [ 1301AC_CHECK_FUNCS(setresuid, [
1289 dnl Some platorms have setresuid that isn't implemented, test for this 1302 dnl Some platorms have setresuid that isn't implemented, test for this
1290 AC_MSG_CHECKING(if setresuid seems to work) 1303 AC_MSG_CHECKING(if setresuid seems to work)