summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-12-02 21:02:22 +1100
committerDarren Tucker <dtucker@zip.com.au>2007-12-02 21:02:22 +1100
commit319b3d9b00a38d0b7d6965173f3507e80bb1f46e (patch)
tree7127e097d5ad3d30e8cc25b279c4a538b5c3824d /configure.ac
parente6d152794949c1e552e154aef6c74ef867991a9b (diff)
- (dtucker) [configure.ac] Enable -fstack-protector-all on systems where
gcc supports it. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e9402a735..c9bce0199 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.386 2007/09/26 21:03:20 dtucker Exp $ 1# $Id: configure.ac,v 1.387 2007/12/02 10:02:22 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.386 $) 18AC_REVISION($Revision: 1.387 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -105,6 +105,15 @@ if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
105 *) ;; 105 *) ;;
106 esac 106 esac
107 107
108 AC_MSG_CHECKING(if $GCC understands -fstack-protector-all)
109 saved_CFLAGS="$CFLAGS"
110 CFLAGS="$CFLAGS -fstack-protector-all"
111 AC_TRY_COMPILE([], [ int main(void){return 0;} ],
112 [ AC_MSG_RESULT(yes) ],
113 [ AC_MSG_RESULT(no)
114 CFLAGS="$saved_CFLAGS" ]
115 )
116
108 if test -z "$have_llong_max"; then 117 if test -z "$have_llong_max"; then
109 # retry LLONG_MAX with -std=gnu99, needed on some Linuxes 118 # retry LLONG_MAX with -std=gnu99, needed on some Linuxes
110 unset ac_cv_have_decl_LLONG_MAX 119 unset ac_cv_have_decl_LLONG_MAX