summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2020-02-21 12:01:36 +0000
commit34aff3aa136e5a65f441b25811dd466488fda087 (patch)
treee2170faeed03d67545255d3d3c9d62280414c0b2 /configure.ac
parentf0de78bd4f29fa688c5df116f3f9cd43543a76d0 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Origin: other, https://github.com/openssh-gsskex/openssh-gsskex/commits/debian/master Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2020-02-21 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b689db4b5..efafb6bd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -674,6 +674,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
674 [Use tunnel device compatibility to OpenBSD]) 674 [Use tunnel device compatibility to OpenBSD])
675 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 675 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
676 [Prepend the address family to IP tunnel traffic]) 676 [Prepend the address family to IP tunnel traffic])
677 AC_MSG_CHECKING([if we have the Security Authorization Session API])
678 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
679 [SessionCreate(0, 0);],
680 [ac_cv_use_security_session_api="yes"
681 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
682 [platform has the Security Authorization Session API])
683 LIBS="$LIBS -framework Security"
684 AC_MSG_RESULT([yes])],
685 [ac_cv_use_security_session_api="no"
686 AC_MSG_RESULT([no])])
687 AC_MSG_CHECKING([if we have an in-memory credentials cache])
688 AC_TRY_COMPILE(
689 [#include <Kerberos/Kerberos.h>],
690 [cc_context_t c;
691 (void) cc_initialize (&c, 0, NULL, NULL);],
692 [AC_DEFINE([USE_CCAPI], [1],
693 [platform uses an in-memory credentials cache])
694 LIBS="$LIBS -framework Security"
695 AC_MSG_RESULT([yes])
696 if test "x$ac_cv_use_security_session_api" = "xno"; then
697 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
698 fi],
699 [AC_MSG_RESULT([no])]
700 )
677 m4_pattern_allow([AU_IPv]) 701 m4_pattern_allow([AU_IPv])
678 AC_CHECK_DECL([AU_IPv4], [], 702 AC_CHECK_DECL([AU_IPv4], [],
679 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 703 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])