diff options
author | Damien Miller <djm@mindrot.org> | 2004-08-15 18:40:59 +1000 |
---|---|---|
committer | Damien Miller <djm@mindrot.org> | 2004-08-15 18:40:59 +1000 |
commit | 36f496502072d82dbb202b41a199eb6032557710 (patch) | |
tree | 439092c6479cb2fea8c09318b37a61370d860638 /configure.ac | |
parent | 25f60a7ee780c2cd4a01e05698149d274821012f (diff) |
- (djm) [acconfig.h configure.ac openbsd-compat/Makefile.in
openbsd-compat/bsd-closefrom.c openbsd-compat/bsd-misc.c
openbsd-compat/bsd-misc.h openbsd-compat/openbsd-compat.h] Use smarter
closefrom() replacement from sudo; ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 30 |
1 files changed, 19 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac index 1579c8dd3..6954fb47e 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.224 2004/07/19 17:19:27 tim Exp $ | 1 | # $Id: configure.ac,v 1.225 2004/08/15 08:40:59 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -517,16 +517,16 @@ int main(){exit(0);} | |||
517 | ) | 517 | ) |
518 | 518 | ||
519 | # Checks for header files. | 519 | # Checks for header files. |
520 | AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \ | 520 | AC_CHECK_HEADERS(bstring.h crypt.h dirent.h endian.h features.h \ |
521 | getopt.h glob.h ia.h lastlog.h limits.h login.h \ | 521 | floatingpoint.h getopt.h glob.h ia.h lastlog.h limits.h login.h \ |
522 | login_cap.h maillock.h netdb.h netgroup.h \ | 522 | login_cap.h maillock.h ndir.h netdb.h netgroup.h \ |
523 | netinet/in_systm.h pam/pam_appl.h paths.h pty.h readpassphrase.h \ | 523 | netinet/in_systm.h pam/pam_appl.h paths.h pty.h readpassphrase.h \ |
524 | rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \ | 524 | rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \ |
525 | strings.h sys/strtio.h sys/audit.h sys/bitypes.h sys/bsdtty.h \ | 525 | strings.h sys/dir.h sys/strtio.h sys/audit.h sys/bitypes.h \ |
526 | sys/cdefs.h sys/mman.h sys/prctl.h sys/pstat.h sys/ptms.h \ | 526 | sys/bsdtty.h sys/cdefs.h sys/mman.h sys/ndir.h sys/prctl.h \ |
527 | sys/select.h sys/stat.h sys/stream.h sys/stropts.h \ | 527 | sys/pstat.h sys/ptms.h sys/select.h sys/stat.h sys/stream.h \ |
528 | sys/sysmacros.h sys/time.h sys/timers.h sys/un.h time.h tmpdir.h \ | 528 | sys/stropts.h sys/sysmacros.h sys/time.h sys/timers.h sys/un.h \ |
529 | ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h) | 529 | time.h tmpdir.h ttyent.h usersec.h util.h utime.h utmp.h utmpx.h vis.h) |
530 | 530 | ||
531 | # Checks for libraries. | 531 | # Checks for libraries. |
532 | AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match)) | 532 | AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match)) |
@@ -731,6 +731,14 @@ int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));} | |||
731 | ] | 731 | ] |
732 | ) | 732 | ) |
733 | 733 | ||
734 | AC_MSG_CHECKING([for /proc/pid/fd directory]) | ||
735 | if test -d "/proc/$$/fd" ; then | ||
736 | AC_DEFINE(HAVE_PROC_PID) | ||
737 | AC_MSG_RESULT(yes) | ||
738 | else | ||
739 | AC_MSG_RESULT(no) | ||
740 | fi | ||
741 | |||
734 | # Check whether user wants S/Key support | 742 | # Check whether user wants S/Key support |
735 | SKEY_MSG="no" | 743 | SKEY_MSG="no" |
736 | AC_ARG_WITH(skey, | 744 | AC_ARG_WITH(skey, |
@@ -833,8 +841,8 @@ AC_ARG_WITH(tcp-wrappers, | |||
833 | dnl Checks for library functions. Please keep in alphabetical order | 841 | dnl Checks for library functions. Please keep in alphabetical order |
834 | AC_CHECK_FUNCS(\ | 842 | AC_CHECK_FUNCS(\ |
835 | arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \ | 843 | arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \ |
836 | bindresvport_sa clock closefrom fchmod fchown freeaddrinfo futimes \ | 844 | bindresvport_sa clock closefrom dirfd fchmod fchown freeaddrinfo \ |
837 | getaddrinfo getcwd getgrouplist getnameinfo getopt \ | 845 | futimes getaddrinfo getcwd getgrouplist getnameinfo getopt \ |
838 | getpeereid _getpty getrlimit getttyent glob inet_aton \ | 846 | getpeereid _getpty getrlimit getttyent glob inet_aton \ |
839 | inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ | 847 | inet_ntoa inet_ntop innetgr login_getcapbool md5_crypt memmove \ |
840 | mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ | 848 | mkdtemp mmap ngetaddrinfo nsleep ogetaddrinfo openlog_r openpty \ |