summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2009-03-07 22:22:35 +1100
committerDarren Tucker <dtucker@zip.com.au>2009-03-07 22:22:35 +1100
commit3e7e15f1bdc2ddd8fe4a389212c6b8db58e2b511 (patch)
treef8ad1aaf09d130d416d8b345f9e2ddc4d8f28c58 /configure.ac
parent30ed668de0f7755934971f2e7e80b62073091624 (diff)
- (dtucker) [configure.ac openbsd-compat/openssl-compat.{c,h}]
EVP_DigestUpdate does not exactly match the other OLD_EVP functions (eg in openssl 0.9.6) so add an explicit test for it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a2cb7a215..51fee9e6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.417 2009/03/07 07:06:22 dtucker Exp $ 1# $Id: configure.ac,v 1.418 2009/03/07 11:22:35 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.417 $) 18AC_REVISION($Revision: 1.418 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -2076,6 +2076,23 @@ int main(void) { exit(EVP_aes_192_cbc() == NULL || EVP_aes_256_cbc() == NULL);}
2076 ] 2076 ]
2077) 2077)
2078 2078
2079AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2080AC_LINK_IFELSE(
2081 [AC_LANG_SOURCE([[
2082#include <string.h>
2083#include <openssl/evp.h>
2084int main(void) { if(EVP_DigestUpdate(NULL, NULL,0)) exit(0); }
2085 ]])],
2086 [
2087 AC_MSG_RESULT(yes)
2088 ],
2089 [
2090 AC_MSG_RESULT(no)
2091 AC_DEFINE(OPENSSL_EVP_DIGESTUPDATE_VOID, 1,
2092 [Define if EVP_DigestUpdate returns void])
2093 ]
2094)
2095
2079# Some systems want crypt() from libcrypt, *not* the version in OpenSSL, 2096# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
2080# because the system crypt() is more featureful. 2097# because the system crypt() is more featureful.
2081if test "x$check_for_libcrypt_before" = "x1"; then 2098if test "x$check_for_libcrypt_before" = "x1"; then