summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2013-11-07 22:33:48 +1100
committerDarren Tucker <dtucker@zip.com.au>2013-11-07 22:33:48 +1100
commit4bf7e50e533aa956366df7402c132f202e841a48 (patch)
tree4a58c369a1107951c418b419e6d09a0e94544819 /configure.ac
parent6e9d6f411288374d1dee4b7debbfa90bc7e73035 (diff)
- (dtucker) [Makefile.in configure.ac] Remove TEST_SSH_SHA256 environment
variable. It's no longer used now that we get the supported MACs from ssh -Q.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e545730d7..31972cf9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.538 2013/11/07 02:28:16 djm Exp $ 1# $Id: configure.ac,v 1.539 2013/11/07 11:33:48 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.538 $) 18AC_REVISION($Revision: 1.539 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2437,16 +2437,13 @@ fi
2437AC_CHECK_FUNCS([crypt DES_crypt]) 2437AC_CHECK_FUNCS([crypt DES_crypt])
2438 2438
2439# Search for SHA256 support in libc and/or OpenSSL 2439# Search for SHA256 support in libc and/or OpenSSL
2440AC_CHECK_FUNCS([SHA256_Update EVP_sha256], 2440AC_CHECK_FUNCS([SHA256_Update EVP_sha256], ,
2441 [TEST_SSH_SHA256=yes], 2441 [unsupported_algorithms="$unsupported_algorithms \
2442 [TEST_SSH_SHA256=no
2443 unsupported_algorithms="$unsupported_algorithms \
2444 hmac-sha2-256 hmac-sha2-512 \ 2442 hmac-sha2-256 hmac-sha2-512 \
2445 diffie-hellman-group-exchange-sha256 \ 2443 diffie-hellman-group-exchange-sha256 \
2446 hmac-sha2-256-etm@openssh.com hmac-sha2-512-etm@openssh.com" 2444 hmac-sha2-256-etm@openssh.com hmac-sha2-512-etm@openssh.com"
2447 ] 2445 ]
2448) 2446)
2449AC_SUBST([TEST_SSH_SHA256])
2450 2447
2451# Check complete ECC support in OpenSSL 2448# Check complete ECC support in OpenSSL
2452AC_MSG_CHECKING([whether OpenSSL has complete ECC support]) 2449AC_MSG_CHECKING([whether OpenSSL has complete ECC support])