diff options
author | Darren Tucker <dtucker@zip.com.au> | 2017-03-29 10:23:58 +1100 |
---|---|---|
committer | Darren Tucker <dtucker@zip.com.au> | 2017-03-29 10:23:58 +1100 |
commit | 5346f271fc76549caf4a8e65b5fba319be422fe9 (patch) | |
tree | f085fef193fce1edff6aa78dd5868badaa84e40f /configure.ac | |
parent | 8fed0a5fe7b4e78a6810b133d8e91be9742ee0a1 (diff) |
Remove check for OpenSSL < 0.9.8g.
We no longer support OpenSSL < 1.0.1 so remove check for unreliable ECC
in OpenSSL < 0.9.8g.
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 9 |
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac index 82b28ce9a..ab58b982b 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -2769,9 +2769,6 @@ if test "x$openssl" = "xyes" ; then | |||
2769 | #include <openssl/evp.h> | 2769 | #include <openssl/evp.h> |
2770 | #include <openssl/objects.h> | 2770 | #include <openssl/objects.h> |
2771 | #include <openssl/opensslv.h> | 2771 | #include <openssl/opensslv.h> |
2772 | #if OPENSSL_VERSION_NUMBER < 0x0090807f /* 0.9.8g */ | ||
2773 | # error "OpenSSL < 0.9.8g has unreliable ECC code" | ||
2774 | #endif | ||
2775 | ]], [[ | 2772 | ]], [[ |
2776 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1); | 2773 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_X9_62_prime256v1); |
2777 | const EVP_MD *m = EVP_sha256(); /* We need this too */ | 2774 | const EVP_MD *m = EVP_sha256(); /* We need this too */ |
@@ -2790,9 +2787,6 @@ if test "x$openssl" = "xyes" ; then | |||
2790 | #include <openssl/evp.h> | 2787 | #include <openssl/evp.h> |
2791 | #include <openssl/objects.h> | 2788 | #include <openssl/objects.h> |
2792 | #include <openssl/opensslv.h> | 2789 | #include <openssl/opensslv.h> |
2793 | #if OPENSSL_VERSION_NUMBER < 0x0090807f /* 0.9.8g */ | ||
2794 | # error "OpenSSL < 0.9.8g has unreliable ECC code" | ||
2795 | #endif | ||
2796 | ]], [[ | 2790 | ]], [[ |
2797 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp384r1); | 2791 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp384r1); |
2798 | const EVP_MD *m = EVP_sha384(); /* We need this too */ | 2792 | const EVP_MD *m = EVP_sha384(); /* We need this too */ |
@@ -2811,9 +2805,6 @@ if test "x$openssl" = "xyes" ; then | |||
2811 | #include <openssl/evp.h> | 2805 | #include <openssl/evp.h> |
2812 | #include <openssl/objects.h> | 2806 | #include <openssl/objects.h> |
2813 | #include <openssl/opensslv.h> | 2807 | #include <openssl/opensslv.h> |
2814 | #if OPENSSL_VERSION_NUMBER < 0x0090807f /* 0.9.8g */ | ||
2815 | # error "OpenSSL < 0.9.8g has unreliable ECC code" | ||
2816 | #endif | ||
2817 | ]], [[ | 2808 | ]], [[ |
2818 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp521r1); | 2809 | EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp521r1); |
2819 | const EVP_MD *m = EVP_sha512(); /* We need this too */ | 2810 | const EVP_MD *m = EVP_sha512(); /* We need this too */ |