diff options
author | Colin Watson <cjwatson@debian.org> | 2014-10-07 13:22:41 +0100 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2019-10-09 23:06:25 +0100 |
commit | 57c1dd662f9259f58a47801e2d4b0f84e973441d (patch) | |
tree | e42f9c8869169b19425b46621e0cbe2b2bda9780 /configure.ac | |
parent | 9da806e67101afdc0d3a1d304659927acf18f5c5 (diff) |
Restore TCP wrappers support
Support for TCP wrappers was dropped in OpenSSH 6.7. See this message
and thread:
https://lists.mindrot.org/pipermail/openssh-unix-dev/2014-April/032497.html
It is true that this reduces preauth attack surface in sshd. On the
other hand, this support seems to be quite widely used, and abruptly
dropping it (from the perspective of users who don't read
openssh-unix-dev) could easily cause more serious problems in practice.
It's not entirely clear what the right long-term answer for Debian is,
but it at least probably doesn't involve dropping this feature shortly
before a freeze.
Forwarded: not-needed
Last-Update: 2019-06-05
Patch-Name: restore-tcp-wrappers.patch
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 1c2512314..e894db9fc 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1521,6 +1521,62 @@ else | |||
1521 | AC_MSG_RESULT([no]) | 1521 | AC_MSG_RESULT([no]) |
1522 | fi | 1522 | fi |
1523 | 1523 | ||
1524 | # Check whether user wants TCP wrappers support | ||
1525 | TCPW_MSG="no" | ||
1526 | AC_ARG_WITH([tcp-wrappers], | ||
1527 | [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)], | ||
1528 | [ | ||
1529 | if test "x$withval" != "xno" ; then | ||
1530 | saved_LIBS="$LIBS" | ||
1531 | saved_LDFLAGS="$LDFLAGS" | ||
1532 | saved_CPPFLAGS="$CPPFLAGS" | ||
1533 | if test -n "${withval}" && \ | ||
1534 | test "x${withval}" != "xyes"; then | ||
1535 | if test -d "${withval}/lib"; then | ||
1536 | if test -n "${need_dash_r}"; then | ||
1537 | LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" | ||
1538 | else | ||
1539 | LDFLAGS="-L${withval}/lib ${LDFLAGS}" | ||
1540 | fi | ||
1541 | else | ||
1542 | if test -n "${need_dash_r}"; then | ||
1543 | LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}" | ||
1544 | else | ||
1545 | LDFLAGS="-L${withval} ${LDFLAGS}" | ||
1546 | fi | ||
1547 | fi | ||
1548 | if test -d "${withval}/include"; then | ||
1549 | CPPFLAGS="-I${withval}/include ${CPPFLAGS}" | ||
1550 | else | ||
1551 | CPPFLAGS="-I${withval} ${CPPFLAGS}" | ||
1552 | fi | ||
1553 | fi | ||
1554 | LIBS="-lwrap $LIBS" | ||
1555 | AC_MSG_CHECKING([for libwrap]) | ||
1556 | AC_LINK_IFELSE([AC_LANG_PROGRAM([[ | ||
1557 | #include <sys/types.h> | ||
1558 | #include <sys/socket.h> | ||
1559 | #include <netinet/in.h> | ||
1560 | #include <tcpd.h> | ||
1561 | int deny_severity = 0, allow_severity = 0; | ||
1562 | ]], [[ | ||
1563 | hosts_access(0); | ||
1564 | ]])], [ | ||
1565 | AC_MSG_RESULT([yes]) | ||
1566 | AC_DEFINE([LIBWRAP], [1], | ||
1567 | [Define if you want | ||
1568 | TCP Wrappers support]) | ||
1569 | SSHDLIBS="$SSHDLIBS -lwrap" | ||
1570 | TCPW_MSG="yes" | ||
1571 | ], [ | ||
1572 | AC_MSG_ERROR([*** libwrap missing]) | ||
1573 | |||
1574 | ]) | ||
1575 | LIBS="$saved_LIBS" | ||
1576 | fi | ||
1577 | ] | ||
1578 | ) | ||
1579 | |||
1524 | # Check whether user wants to use ldns | 1580 | # Check whether user wants to use ldns |
1525 | LDNS_MSG="no" | 1581 | LDNS_MSG="no" |
1526 | AC_ARG_WITH(ldns, | 1582 | AC_ARG_WITH(ldns, |
@@ -5242,6 +5298,7 @@ echo " PAM support: $PAM_MSG" | |||
5242 | echo " OSF SIA support: $SIA_MSG" | 5298 | echo " OSF SIA support: $SIA_MSG" |
5243 | echo " KerberosV support: $KRB5_MSG" | 5299 | echo " KerberosV support: $KRB5_MSG" |
5244 | echo " SELinux support: $SELINUX_MSG" | 5300 | echo " SELinux support: $SELINUX_MSG" |
5301 | echo " TCP Wrappers support: $TCPW_MSG" | ||
5245 | echo " MD5 password support: $MD5_MSG" | 5302 | echo " MD5 password support: $MD5_MSG" |
5246 | echo " libedit support: $LIBEDIT_MSG" | 5303 | echo " libedit support: $LIBEDIT_MSG" |
5247 | echo " libldns support: $LDNS_MSG" | 5304 | echo " libldns support: $LDNS_MSG" |