summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2020-01-26 13:40:51 +1100
committerDarren Tucker <dtucker@dtucker.net>2020-01-26 14:05:40 +1100
commit638a45b5c1e20a8539100ca44166caad8abf26f8 (patch)
treee82188f6699bd5dfcf4b40fe7f4afd0eaff8c333 /configure.ac
parent74dfc2c859c906eaab1f88a27fd883115ffb928f (diff)
Wrap stdint.h in tests inside HAVE_STDINT_H.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 34cd94a7f..b689db4b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1564,7 +1564,9 @@ AC_ARG_WITH(ldns,
1564 [AC_LANG_SOURCE([[ 1564 [AC_LANG_SOURCE([[
1565#include <stdio.h> 1565#include <stdio.h>
1566#include <stdlib.h> 1566#include <stdlib.h>
1567#include <stdint.h> 1567#ifdef HAVE_STDINT_H
1568# include <stdint.h>
1569#endif
1568#include <ldns/ldns.h> 1570#include <ldns/ldns.h>
1569int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); } 1571int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); }
1570 ]]) 1572 ]])
@@ -3849,7 +3851,9 @@ fi
3849 3851
3850AC_CHECK_TYPES([intmax_t, uintmax_t], , , [ 3852AC_CHECK_TYPES([intmax_t, uintmax_t], , , [
3851#include <sys/types.h> 3853#include <sys/types.h>
3852#include <stdint.h> 3854#ifdef HAVE_STDINT_H
3855# include <stdint.h>
3856#endif
3853]) 3857])
3854 3858
3855TYPE_SOCKLEN_T 3859TYPE_SOCKLEN_T