summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2020-06-07 10:24:45 +0100
commit79f9d21b406c172878896ef41cdc2502fc2f84a7 (patch)
tree71507aaefd925223b1543b10f4342f2df9ea0ee3 /configure.ac
parent202f5a676221c244cd450086c334c2b59f339e86 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Author: Simon Wilkinson <simon@sxw.org.uk> Author: Colin Watson <cjwatson@debian.org> Author: Jakub Jelen <jjelen@redhat.com> Origin: other, https://github.com/openssh-gsskex/openssh-gsskex/commits/debian/master Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2020-06-07 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 460383757..d98e6f74a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -676,6 +676,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
676 [Use tunnel device compatibility to OpenBSD]) 676 [Use tunnel device compatibility to OpenBSD])
677 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 677 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
678 [Prepend the address family to IP tunnel traffic]) 678 [Prepend the address family to IP tunnel traffic])
679 AC_MSG_CHECKING([if we have the Security Authorization Session API])
680 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
681 [SessionCreate(0, 0);],
682 [ac_cv_use_security_session_api="yes"
683 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
684 [platform has the Security Authorization Session API])
685 LIBS="$LIBS -framework Security"
686 AC_MSG_RESULT([yes])],
687 [ac_cv_use_security_session_api="no"
688 AC_MSG_RESULT([no])])
689 AC_MSG_CHECKING([if we have an in-memory credentials cache])
690 AC_TRY_COMPILE(
691 [#include <Kerberos/Kerberos.h>],
692 [cc_context_t c;
693 (void) cc_initialize (&c, 0, NULL, NULL);],
694 [AC_DEFINE([USE_CCAPI], [1],
695 [platform uses an in-memory credentials cache])
696 LIBS="$LIBS -framework Security"
697 AC_MSG_RESULT([yes])
698 if test "x$ac_cv_use_security_session_api" = "xno"; then
699 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
700 fi],
701 [AC_MSG_RESULT([no])]
702 )
679 m4_pattern_allow([AU_IPv]) 703 m4_pattern_allow([AU_IPv])
680 AC_CHECK_DECL([AU_IPv4], [], 704 AC_CHECK_DECL([AU_IPv4], [],
681 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 705 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])