summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2018-11-16 13:32:13 +1100
committerDarren Tucker <dtucker@dtucker.net>2018-11-16 13:32:13 +1100
commit8d8340e2c215155637fe19cb1a837f71b2d55f7b (patch)
treef2d5d66427be96161b8abfd23179064ad6e45ff5 /configure.ac
parentce93472134fb22eff73edbcd173a21ae38889331 (diff)
Remove fallback check for /usr/local/ssl.
If configure could not find a working OpenSSL installation it would fall back to checking in /usr/local/ssl. This made sense back when systems did not ship with OpenSSL, but most do and OpenSSL 1.1 doesn't use that as a default any more. The fallback behaviour also meant that if you pointed --with-ssl-dir at a specific directory and it didn't work, it would silently use either the system libs or the ones in /usr/local/ssl. If you want to use /usr/local/ssl you'll need to pass configure --with-ssl-dir=/usr/local/ssl. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 4 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 0660c5397..53a16c39a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2527,26 +2527,10 @@ AC_ARG_WITH([ssl-engine],
2527 2527
2528if test "x$openssl" = "xyes" ; then 2528if test "x$openssl" = "xyes" ; then
2529 LIBS="-lcrypto $LIBS" 2529 LIBS="-lcrypto $LIBS"
2530 AC_TRY_LINK_FUNC([RAND_add], [AC_DEFINE([HAVE_OPENSSL], [1], 2530 AC_TRY_LINK_FUNC([RAND_add], ,
2531 [Define if your ssl headers are included 2531 [AC_MSG_ERROR([*** working libcrypto not found, check config.log])])
2532 with #include <openssl/header.h>])], 2532 AC_CHECK_HEADER([openssl/opensslv.h], ,
2533 [ 2533 [AC_MSG_ERROR([*** OpenSSL headers missing - please install first or check config.log ***])])
2534 dnl Check default openssl install dir
2535 if test -n "${need_dash_r}"; then
2536 LDFLAGS="-L/usr/local/ssl/lib -R/usr/local/ssl/lib ${saved_LDFLAGS}"
2537 else
2538 LDFLAGS="-L/usr/local/ssl/lib ${saved_LDFLAGS}"
2539 fi
2540 CPPFLAGS="-I/usr/local/ssl/include ${saved_CPPFLAGS}"
2541 AC_CHECK_HEADER([openssl/opensslv.h], ,
2542 [AC_MSG_ERROR([*** OpenSSL headers missing - please install first or check config.log ***])])
2543 AC_TRY_LINK_FUNC([RAND_add], [AC_DEFINE([HAVE_OPENSSL])],
2544 [
2545 AC_MSG_ERROR([*** Can't find recent OpenSSL libcrypto (see config.log for details) ***])
2546 ]
2547 )
2548 ]
2549 )
2550 2534
2551 # Determine OpenSSL header version 2535 # Determine OpenSSL header version
2552 AC_MSG_CHECKING([OpenSSL header version]) 2536 AC_MSG_CHECKING([OpenSSL header version])