summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2010-11-05 12:03:05 +1100
committerDarren Tucker <dtucker@zip.com.au>2010-11-05 12:03:05 +1100
commit97528353c2b4f27169ea9b81e5c4420c734ceea2 (patch)
tree7f373a0ff2a453fc4b86c3467501c485dd510e44 /configure.ac
parent34ee4204c6051f5f48113903750738e8e055a778 (diff)
- (dtucker) [configure.ac platform.{c,h} session.c
openbsd-compat/port-solaris.{c,h}] Bug #1824: Add Solaris Project support. Patch from cory.erickson at csu mnscu edu with a bit of rework from me. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2b57e8e06..39b68c70a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.455 2010/10/11 11:35:23 djm Exp $ 1# $Id: configure.ac,v 1.456 2010/11/05 01:03:05 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.455 $) 18AC_REVISION($Revision: 1.456 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -333,6 +333,7 @@ AC_CHECK_HEADERS(sys/mount.h, [], [], [
333# Messages for features tested for in target-specific section 333# Messages for features tested for in target-specific section
334SIA_MSG="no" 334SIA_MSG="no"
335SPC_MSG="no" 335SPC_MSG="no"
336SP_MSG="no"
336 337
337# Check for some target-specific stuff 338# Check for some target-specific stuff
338case "$host" in 339case "$host" in
@@ -704,6 +705,17 @@ mips-sony-bsd|mips-sony-newsos4)
704 SPC_MSG="yes" ], ) 705 SPC_MSG="yes" ], )
705 ], 706 ],
706 ) 707 )
708 AC_ARG_WITH(solaris-projects,
709 [ --with-solaris-projects Enable Solaris projects (experimental)],
710 [
711 AC_CHECK_LIB(project, setproject,
712 [ AC_DEFINE(USE_SOLARIS_PROJECTS, 1,
713 [Define if you have Solaris projects])
714 SSHDLIBS="$SSHDLIBS -lproject"
715 AC_SUBST(SSHDLIBS)
716 SP_MSG="yes" ], )
717 ],
718 )
707 ;; 719 ;;
708*-*-sunos4*) 720*-*-sunos4*)
709 CPPFLAGS="$CPPFLAGS -DSUNOS4" 721 CPPFLAGS="$CPPFLAGS -DSUNOS4"
@@ -4236,6 +4248,7 @@ echo " TCP Wrappers support: $TCPW_MSG"
4236echo " MD5 password support: $MD5_MSG" 4248echo " MD5 password support: $MD5_MSG"
4237echo " libedit support: $LIBEDIT_MSG" 4249echo " libedit support: $LIBEDIT_MSG"
4238echo " Solaris process contract support: $SPC_MSG" 4250echo " Solaris process contract support: $SPC_MSG"
4251echo " Solaris project support: $SP_MSG"
4239echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4252echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4240echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4253echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4241echo " BSD Auth support: $BSD_AUTH_MSG" 4254echo " BSD Auth support: $BSD_AUTH_MSG"