diff options
author | Damien Miller <djm@mindrot.org> | 2007-03-05 11:51:27 +1100 |
---|---|---|
committer | Damien Miller <djm@mindrot.org> | 2007-03-05 11:51:27 +1100 |
commit | 9975e483498430b8fa75fccd2bad681781df24d1 (patch) | |
tree | 93ead8654014f5a9cc1c39a88d28bbbf3bd0451a /configure.ac | |
parent | 90a58fdf22abf77020fb9d3a6bad4fa97f6e3489 (diff) |
- (djm) [configure.ac] add a --without-openssl-header-check option to
configure, as some platforms (OS X) ship OpenSSL headers whose version
does not match that of the shipping library. ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 25 |
1 files changed, 21 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac index b6a25c9e0..a2b236355 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.371 2007/03/02 06:50:04 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.372 2007/03/05 00:51:27 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) | 17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) |
18 | AC_REVISION($Revision: 1.371 $) | 18 | AC_REVISION($Revision: 1.372 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | 20 | ||
21 | AC_CONFIG_HEADER(config.h) | 21 | AC_CONFIG_HEADER(config.h) |
@@ -1857,6 +1857,14 @@ int main(void) { | |||
1857 | ] | 1857 | ] |
1858 | ) | 1858 | ) |
1859 | 1859 | ||
1860 | AC_ARG_WITH(openssl-header-check, | ||
1861 | [ --without-openssl-header-check Disable OpenSSL version consistency check], | ||
1862 | [ if test "x$withval" = "xno" ; then | ||
1863 | openssl_check_nonfatal=1 | ||
1864 | fi | ||
1865 | ] | ||
1866 | ) | ||
1867 | |||
1860 | # Sanity check OpenSSL headers | 1868 | # Sanity check OpenSSL headers |
1861 | AC_MSG_CHECKING([whether OpenSSL's headers match the library]) | 1869 | AC_MSG_CHECKING([whether OpenSSL's headers match the library]) |
1862 | AC_RUN_IFELSE( | 1870 | AC_RUN_IFELSE( |
@@ -1870,9 +1878,18 @@ int main(void) { exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); } | |||
1870 | ], | 1878 | ], |
1871 | [ | 1879 | [ |
1872 | AC_MSG_RESULT(no) | 1880 | AC_MSG_RESULT(no) |
1873 | AC_MSG_ERROR([Your OpenSSL headers do not match your library. | 1881 | if test "x$openssl_check_nonfatal" = "x"; then |
1874 | Check config.log for details. | 1882 | AC_MSG_ERROR([Your OpenSSL headers do not match your |
1883 | library. Check config.log for details. | ||
1884 | If you are sure your installation is consistent, you can disable the check | ||
1885 | by running "./configure --without-openssl-header-check". | ||
1886 | Also see contrib/findssl.sh for help identifying header/library mismatches. | ||
1887 | ]) | ||
1888 | else | ||
1889 | AC_MSG_WARN([Your OpenSSL headers do not match your | ||
1890 | library. Check config.log for details. | ||
1875 | Also see contrib/findssl.sh for help identifying header/library mismatches.]) | 1891 | Also see contrib/findssl.sh for help identifying header/library mismatches.]) |
1892 | fi | ||
1876 | ], | 1893 | ], |
1877 | [ | 1894 | [ |
1878 | AC_MSG_WARN([cross compiling: not checking]) | 1895 | AC_MSG_WARN([cross compiling: not checking]) |