summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2003-05-15 11:12:19 +1000
committerDamien Miller <djm@mindrot.org>2003-05-15 11:12:19 +1000
commit9d2be48b8fe5c3f54e932e578e3029ebe0a773fb (patch)
treebca403c0625655134e895703d761f028426a8d36 /configure.ac
parent7abe09bf86b0ce437dfbf5dd7ccafadd1f39289e (diff)
better glue w/ jakob@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 7 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 000fb4bc3..c8a991378 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.118 2003/05/15 00:53:49 djm Exp $ 1# $Id: configure.ac,v 1.119 2003/05/15 01:12:19 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1859,26 +1859,15 @@ AC_ARG_WITH(dns,
1859 [ --with-dns Support for fetching keys from DNS (experimental)], 1859 [ --with-dns Support for fetching keys from DNS (experimental)],
1860 [ 1860 [
1861 if test "x$withval" != "xno" ; then 1861 if test "x$withval" != "xno" ; then
1862 AC_DEFINE(DNS) 1862 DNS_MSG="no (system lacks getrrsetbyname)"
1863 DNS_MSG="yes" 1863 AC_SEARCH_LIBS(getrrsetbyname, resolv, [
1864 fi 1864 AC_DEFINE(DNS)
1865 ] 1865 DNS_MSG="yes"
1866) 1866 ])
1867
1868LWRES_MSG=""
1869AC_ARG_WITH(lwres,
1870 [ --with-lwres Use lwres library/headers for DNS support],
1871 [
1872 if test "x$withval" != "xno" -a "x$DNS_MSG" = "xyes"; then
1873 AC_DEFINE(LWRES)
1874 LWRES_MSG="(using liblwres)"
1875 AC_SEARCH_LIBS(lwres_herror, lwres)
1876 fi 1867 fi
1877 ] 1868 ]
1878) 1869)
1879 1870
1880
1881
1882# Check whether user wants Kerberos 5 support 1871# Check whether user wants Kerberos 5 support
1883KRB5_MSG="no" 1872KRB5_MSG="no"
1884AC_ARG_WITH(kerberos5, 1873AC_ARG_WITH(kerberos5,
@@ -2603,7 +2592,7 @@ if test ! -z "$superuser_path" ; then
2603echo " sshd superuser user PATH: $J" 2592echo " sshd superuser user PATH: $J"
2604fi 2593fi
2605echo " Manpage format: $MANTYPE" 2594echo " Manpage format: $MANTYPE"
2606echo " DNS support: $DNS_MSG $LWRES_MSG" 2595echo " DNS support: $DNS_MSG"
2607echo " PAM support: $PAM_MSG" 2596echo " PAM support: $PAM_MSG"
2608echo " KerberosIV support: $KRB4_MSG" 2597echo " KerberosIV support: $KRB4_MSG"
2609echo " KerberosV support: $KRB5_MSG" 2598echo " KerberosV support: $KRB5_MSG"