summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2004-01-30 14:20:59 +1100
committerDarren Tucker <dtucker@zip.com.au>2004-01-30 14:20:59 +1100
commitdcc736b7de2206c391e46289f096f60426f7d418 (patch)
tree68449344dbdde36df3b37c2abe196dd7dbe3707e /configure.ac
parent46662bfc21dad33f8d7c05206bae15f79abe5b5f (diff)
- (dtucker) [configure.ac] Add --without-zlib-version-check. Feedback from
tim@, ok several
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 21 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3b04182d5..c037ee7c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.189 2004/01/27 03:03:39 tim Exp $ 1# $Id: configure.ac,v 1.190 2004/01/30 03:20:59 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -580,6 +580,15 @@ AC_CHECK_LIB(z, deflate, ,
580 ] 580 ]
581) 581)
582AC_CHECK_HEADER([zlib.h], ,AC_MSG_ERROR([*** zlib.h missing - please install first or check config.log ***])) 582AC_CHECK_HEADER([zlib.h], ,AC_MSG_ERROR([*** zlib.h missing - please install first or check config.log ***]))
583
584AC_ARG_WITH(zlib-version-check,
585 [ --without-zlib-version-check Disable zlib version check],
586 [ if test "x$withval" = "xno" ; then
587 zlib_check_nonfatal=1
588 fi
589 ]
590)
591
583AC_MSG_CHECKING(for zlib 1.1.4 or greater) 592AC_MSG_CHECKING(for zlib 1.1.4 or greater)
584AC_TRY_RUN([ 593AC_TRY_RUN([
585#include <zlib.h> 594#include <zlib.h>
@@ -596,9 +605,18 @@ int main()
596 ], 605 ],
597 AC_MSG_RESULT(yes), 606 AC_MSG_RESULT(yes),
598 [ AC_MSG_RESULT(no) 607 [ AC_MSG_RESULT(no)
599 AC_MSG_ERROR([*** zlib too old - check config.log ***]) ] 608 if test -z "$zlib_check_nonfatal" ; then
609 AC_MSG_ERROR([*** zlib too old - check config.log ***
610Your reported zlib version has known security problems. It's possible your
611vendor has fixed these problems without changing the version number. If you
612are sure this is the case, you can disable the check by running
613"./configure --without-zlib-version-check".
614If you are in doubt, upgrade zlib to version 1.1.4 or greater.])
615 else
616 AC_MSG_WARN([zlib version may have security problems])
617 fi
618 ]
600) 619)
601
602 620
603dnl UnixWare 2.x 621dnl UnixWare 2.x
604AC_CHECK_FUNC(strcasecmp, 622AC_CHECK_FUNC(strcasecmp,