summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2014-01-18 21:12:42 +1100
committerDarren Tucker <dtucker@zip.com.au>2014-01-18 21:12:42 +1100
commitfdce3731660699b2429e93e822f2ccbaccd163ae (patch)
tree2f80622e6f2fec28032b21b106e663a3040f33a6 /configure.ac
parent1411c9263f46e1ee49d0d302bf7258ebe69ce827 (diff)
- (dtucker) [configure.ac] On Cygwin the getopt variables (like optargs,
optind) are defined in getopt.h already. Unfortunately they are defined as "declspec(dllimport)" for historical reasons, because the GNU linker didn't allow auto-import on PE/COFF targets way back when. The problem is the dllexport attributes collide with the definitions in the various source files in OpenSSH, which obviousy define the variables without declspec(dllimport). The least intrusive way to get rid of these warnings is to disable warnings for GCC compiler attributes when building on Cygwin. Patch from vinschen at redhat.com.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f9d87e4b3..76784c52c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.554 2014/01/17 10:54:32 dtucker Exp $ 1# $Id: configure.ac,v 1.555 2014/01/18 10:12:43 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.554 $) 18AC_REVISION($Revision: 1.555 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -544,7 +544,10 @@ case "$host" in
544 [Define if your platform needs to skip post auth 544 [Define if your platform needs to skip post auth
545 file descriptor passing]) 545 file descriptor passing])
546 AC_DEFINE([SSH_IOBUFSZ], [65535], [Windows is sensitive to read buffer size]) 546 AC_DEFINE([SSH_IOBUFSZ], [65535], [Windows is sensitive to read buffer size])
547 AC_DEFINE([FILESYSTEM_NO_BACKSLASH], [1], [File names may not contain backslash characters]) 547 AC_DEFINE([FILESYSTEM_NO_BACKSLASH], [1], [File names may not contain backslash characters])
548 # Cygwin defines optargs, optargs as declspec(dllimport) for historical
549 # reasons which cause compile warnings, so we disable those warnings.
550 OSSH_CHECK_CFLAG_COMPILE([-Wno-attributes])
548 ;; 551 ;;
549*-*-dgux*) 552*-*-dgux*)
550 AC_DEFINE([IP_TOS_IS_BROKEN], [1], 553 AC_DEFINE([IP_TOS_IS_BROKEN], [1],