summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2014-02-09 16:09:57 +0000
committerColin Watson <cjwatson@debian.org>2014-02-09 23:43:40 +0000
commit05609b1cb381eafb999214bf4a95138e63abdbf2 (patch)
treef6adc60829e0310ab4fcafca21d7f1b9d62c88c0 /configure.ac
parent84589dc348c43ec22b50ede0c2946cf6afd0980d (diff)
Add support for registering ConsoleKit sessions on login
Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1450 Last-Updated: 2013-09-14 Patch-Name: consolekit.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c1a6589e..d7d500a33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3841,6 +3841,30 @@ AC_ARG_WITH([kerberos5],
3841AC_SUBST([GSSLIBS]) 3841AC_SUBST([GSSLIBS])
3842AC_SUBST([K5LIBS]) 3842AC_SUBST([K5LIBS])
3843 3843
3844# Check whether user wants ConsoleKit support
3845CONSOLEKIT_MSG="no"
3846LIBCK_CONNECTOR=""
3847AC_ARG_WITH(consolekit,
3848 [ --with-consolekit Enable ConsoleKit support],
3849 [ if test "x$withval" != "xno" ; then
3850 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
3851 if test "$PKGCONFIG" != "no"; then
3852 AC_MSG_CHECKING([for ck-connector])
3853 if $PKGCONFIG --exists ck-connector; then
3854 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
3855 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
3856 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
3857 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
3858 AC_MSG_RESULT([yes])
3859 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
3860 CONSOLEKIT_MSG="yes"
3861 else
3862 AC_MSG_RESULT([no])
3863 fi
3864 fi
3865 fi ]
3866)
3867
3844# Looking for programs, paths and files 3868# Looking for programs, paths and files
3845 3869
3846PRIVSEP_PATH=/var/empty 3870PRIVSEP_PATH=/var/empty
@@ -4641,6 +4665,7 @@ echo " MD5 password support: $MD5_MSG"
4641echo " libedit support: $LIBEDIT_MSG" 4665echo " libedit support: $LIBEDIT_MSG"
4642echo " Solaris process contract support: $SPC_MSG" 4666echo " Solaris process contract support: $SPC_MSG"
4643echo " Solaris project support: $SP_MSG" 4667echo " Solaris project support: $SP_MSG"
4668echo " ConsoleKit support: $CONSOLEKIT_MSG"
4644echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4669echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4645echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4670echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4646echo " BSD Auth support: $BSD_AUTH_MSG" 4671echo " BSD Auth support: $BSD_AUTH_MSG"