summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2004-12-08 18:29:58 -0800
committerTim Rice <tim@multitalents.net>2004-12-08 18:29:58 -0800
commit0f83d2907cc227b46ebd3e9771534b2c50cbd139 (patch)
treea9a1a75cabf97eaec3964cc5665d1678abc2735f /configure.ac
parent641b34c72b8509283b04c7f78e1ef88f25b8cb9b (diff)
[configure.ac] Comment some non obvious platforms in the target-specific
case statement. Suggested and OK by dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f60bbdd27..4b40b768a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.233 2004/11/07 09:14:34 dtucker Exp $ 1# $Id: configure.ac,v 1.234 2004/12/09 02:29:59 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -348,12 +348,14 @@ mips-sony-bsd|mips-sony-newsos4)
348 # Attention: always take care to bind libsocket and libnsl before libc, 348 # Attention: always take care to bind libsocket and libnsl before libc,
349 # otherwise you will find lots of "SIOCGPGRP errno 22" on syslog 349 # otherwise you will find lots of "SIOCGPGRP errno 22" on syslog
350 ;; 350 ;;
351# UnixWare 1.x, UnixWare 2.x, and others based on code from Univel.
351*-*-sysv4.2*) 352*-*-sysv4.2*)
352 AC_DEFINE(USE_PIPES) 353 AC_DEFINE(USE_PIPES)
353 AC_DEFINE(SETEUID_BREAKS_SETUID) 354 AC_DEFINE(SETEUID_BREAKS_SETUID)
354 AC_DEFINE(BROKEN_SETREUID) 355 AC_DEFINE(BROKEN_SETREUID)
355 AC_DEFINE(BROKEN_SETREGID) 356 AC_DEFINE(BROKEN_SETREGID)
356 ;; 357 ;;
358# UnixWare 7.x, OpenUNIX 8
357*-*-sysv5*) 359*-*-sysv5*)
358 AC_DEFINE(USE_PIPES) 360 AC_DEFINE(USE_PIPES)
359 AC_DEFINE(SETEUID_BREAKS_SETUID) 361 AC_DEFINE(SETEUID_BREAKS_SETUID)
@@ -362,6 +364,7 @@ mips-sony-bsd|mips-sony-newsos4)
362 ;; 364 ;;
363*-*-sysv*) 365*-*-sysv*)
364 ;; 366 ;;
367# SCO UNIX and OEM versions of SCO UNIX
365*-*-sco3.2v4*) 368*-*-sco3.2v4*)
366 CPPFLAGS="$CPPFLAGS -Dftruncate=chsize" 369 CPPFLAGS="$CPPFLAGS -Dftruncate=chsize"
367 LIBS="$LIBS -los -lprot -lcrypt_i -lx -ltinfo -lm" 370 LIBS="$LIBS -los -lprot -lcrypt_i -lx -ltinfo -lm"
@@ -381,6 +384,7 @@ mips-sony-bsd|mips-sony-newsos4)
381 do_sco3_extra_lib_check=yes 384 do_sco3_extra_lib_check=yes
382 TEST_SHELL=ksh 385 TEST_SHELL=ksh
383 ;; 386 ;;
387# SCO OpenServer 5.x
384*-*-sco3.2v5*) 388*-*-sco3.2v5*)
385 if test -z "$GCC"; then 389 if test -z "$GCC"; then
386 CFLAGS="$CFLAGS -belf" 390 CFLAGS="$CFLAGS -belf"