summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2010-02-10 10:19:29 +1100
committerDamien Miller <djm@mindrot.org>2010-02-10 10:19:29 +1100
commit1d2bfc41180087391303145f1bec9f4f4f7cd8fb (patch)
treec77faaf196514723feb14b0babde1402f80f36d2 /configure.ac
parentb401f922b20347b60ef55ae032611d09734016c8 (diff)
- (djm) add -lselinux to LIBS before calling AC_CHECK_FUNCS for
getseuserbyname; patch from calebcase AT gmail.com via cjwatson AT debian.org
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e5de6f58b..5fc1d4a46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.439 2010/01/22 18:25:15 tim Exp $ 1# $Id: configure.ac,v 1.440 2010/02/09 23:19:29 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.439 $) 18AC_REVISION($Revision: 1.440 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -3413,9 +3413,12 @@ AC_ARG_WITH(selinux,
3413 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) 3413 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
3414 SELINUX_MSG="yes" 3414 SELINUX_MSG="yes"
3415 AC_CHECK_HEADER([selinux/selinux.h], , 3415 AC_CHECK_HEADER([selinux/selinux.h], ,
3416 AC_MSG_ERROR(SELinux support requires selinux.h header)) 3416 AC_MSG_ERROR(SELinux support requires selinux.h header))
3417 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], 3417 AC_CHECK_LIB(selinux, setexeccon,
3418 AC_MSG_ERROR(SELinux support requires libselinux library)) 3418 [ LIBSELINUX="-lselinux"
3419 LIBS="$LIBS -lselinux"
3420 ],
3421 AC_MSG_ERROR(SELinux support requires libselinux library))
3419 SSHDLIBS="$SSHDLIBS $LIBSELINUX" 3422 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
3420 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) 3423 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3421 LIBS="$save_LIBS" 3424 LIBS="$save_LIBS"