summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2002-09-23 16:54:10 -0700
committerTim Rice <tim@multitalents.net>2002-09-23 16:54:10 -0700
commit2c961cecb008de61eb0fdd220f406d08a788ee55 (patch)
treef35ecee63557b298bac472682ad0095ed024b7aa /configure.ac
parent6f0a188857a459b743d27045cdb8760c903ad3d3 (diff)
[configure.ac] s/return/exit/ patch by dtucker@zip.com.au
From autoconf guidelines: "Test programs should exit, not return, from main, because on some systems (old Suns, at least) the argument to return in main is ignored."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 84e6adec4..f88d993e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.87 2002/09/12 00:33:00 djm Exp $ 1# $Id: configure.ac,v 1.88 2002/09/23 23:54:12 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -497,7 +497,7 @@ AC_TRY_RUN(
497 [ 497 [
498#include <sys/types.h> 498#include <sys/types.h>
499#include <dirent.h> 499#include <dirent.h>
500int main(void){struct dirent d;return(sizeof(d.d_name)<=sizeof(char));} 500int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
501 ], 501 ],
502 [AC_MSG_RESULT(yes)], 502 [AC_MSG_RESULT(yes)],
503 [ 503 [
@@ -528,7 +528,7 @@ AC_ARG_WITH(skey,
528 [ 528 [
529#include <stdio.h> 529#include <stdio.h>
530#include <skey.h> 530#include <skey.h>
531int main() { char *ff = skey_keyinfo(""); ff=""; return 0; } 531int main() { char *ff = skey_keyinfo(""); ff=""; exit(0); }
532 ], 532 ],
533 [AC_MSG_RESULT(yes)], 533 [AC_MSG_RESULT(yes)],
534 [ 534 [
@@ -668,7 +668,7 @@ if test "x$ac_cv_func_snprintf" = "xyes" ; then
668 AC_TRY_RUN( 668 AC_TRY_RUN(
669 [ 669 [
670#include <stdio.h> 670#include <stdio.h>
671int main(void){char b[5];snprintf(b,5,"123456789");return(b[4]!='\0');} 671int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
672 ], 672 ],
673 [AC_MSG_RESULT(yes)], 673 [AC_MSG_RESULT(yes)],
674 [ 674 [
@@ -851,7 +851,7 @@ AC_TRY_RUN(
851 [ 851 [
852#include <string.h> 852#include <string.h>
853#include <openssl/opensslv.h> 853#include <openssl/opensslv.h>
854int main(void) { return(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); } 854int main(void) { exit(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); }
855 ], 855 ],
856 [ 856 [
857 AC_MSG_RESULT(yes) 857 AC_MSG_RESULT(yes)
@@ -877,7 +877,7 @@ AC_TRY_RUN(
877 [ 877 [
878#include <string.h> 878#include <string.h>
879#include <openssl/rand.h> 879#include <openssl/rand.h>
880int main(void) { return(RAND_status() == 1 ? 0 : 1); } 880int main(void) { exit(RAND_status() == 1 ? 0 : 1); }
881 ], 881 ],
882 [ 882 [
883 OPENSSL_SEEDS_ITSELF=yes 883 OPENSSL_SEEDS_ITSELF=yes