summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2012-10-31 10:35:38 +0000
committerColin Watson <cjwatson@debian.org>2012-10-31 10:35:38 +0000
commit301aad188299b268452af6b67261336c88f44ab1 (patch)
tree5ec34d429196f17ea6eb2205ca8f96da32b09dd1 /configure.ac
parent5cb249b209c170d817471b575b6d105094f137bc (diff)
* Merge from Ubuntu:
- Add support for registering ConsoleKit sessions on login. (This is currently enabled only when building for Ubuntu.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f3718537f..fabd3e0f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3672,6 +3672,30 @@ AC_ARG_WITH([kerberos5],
3672 ] 3672 ]
3673) 3673)
3674 3674
3675# Check whether user wants ConsoleKit support
3676CONSOLEKIT_MSG="no"
3677LIBCK_CONNECTOR=""
3678AC_ARG_WITH(consolekit,
3679 [ --with-consolekit Enable ConsoleKit support],
3680 [ if test "x$withval" != "xno" ; then
3681 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
3682 if test "$PKGCONFIG" != "no"; then
3683 AC_MSG_CHECKING([for ck-connector])
3684 if $PKGCONFIG --exists ck-connector; then
3685 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
3686 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
3687 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
3688 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
3689 AC_MSG_RESULT([yes])
3690 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
3691 CONSOLEKIT_MSG="yes"
3692 else
3693 AC_MSG_RESULT([no])
3694 fi
3695 fi
3696 fi ]
3697)
3698
3675# Looking for programs, paths and files 3699# Looking for programs, paths and files
3676 3700
3677PRIVSEP_PATH=/var/empty 3701PRIVSEP_PATH=/var/empty
@@ -4435,6 +4459,7 @@ echo " MD5 password support: $MD5_MSG"
4435echo " libedit support: $LIBEDIT_MSG" 4459echo " libedit support: $LIBEDIT_MSG"
4436echo " Solaris process contract support: $SPC_MSG" 4460echo " Solaris process contract support: $SPC_MSG"
4437echo " Solaris project support: $SP_MSG" 4461echo " Solaris project support: $SP_MSG"
4462echo " ConsoleKit support: $CONSOLEKIT_MSG"
4438echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4463echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4439echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4464echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4440echo " BSD Auth support: $BSD_AUTH_MSG" 4465echo " BSD Auth support: $BSD_AUTH_MSG"