summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-09-14 23:42:11 +0100
committerColin Watson <cjwatson@debian.org>2013-09-14 23:42:11 +0100
commit327155e6824b3ee13837bdde04e4eb47e147ff46 (patch)
tree8f8743122403c7a2e6ed919156711fb1520c657f /configure.ac
parent0334ce32304e9ba2a10ee5ca49ca6e8ff3ba6cf4 (diff)
parent74e339b8f8936bc0d985e053a076d0c9b5e9ea51 (diff)
* New upstream release (http://www.openssh.com/txt/release-6.3).
- sftp(1): add support for resuming partial downloads using the "reget" command and on the sftp commandline or on the "get" commandline using the "-a" (append) option (closes: #158590). - ssh(1): add an "IgnoreUnknown" configuration option to selectively suppress errors arising from unknown configuration directives (closes: #436052). - sftp(1): update progressmeter when data is acknowledged, not when it's sent (partially addresses #708372). - ssh(1): do not fatally exit when attempting to cleanup multiplexing- created channels that are incompletely opened (closes: #651357).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac147
1 files changed, 94 insertions, 53 deletions
diff --git a/configure.ac b/configure.ac
index 198a2056e..d7d500a33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.518 2013/03/20 01:55:15 djm Exp $ 1# $Id: configure.ac,v 1.536 2013/08/04 11:48:41 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.518 $) 18AC_REVISION($Revision: 1.536 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -129,11 +129,16 @@ AC_ARG_WITH([stackprotect],
129 129
130 130
131if test "$GCC" = "yes" || test "$GCC" = "egcs"; then 131if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
132 OSSH_CHECK_CFLAG_COMPILE([-Qunused-arguments -Werror],
133 [-Qunused-arguments])
134 OSSH_CHECK_CFLAG_COMPILE([-Wunknown-warning-option -Werror],
135 [-Wno-unknown-warning-option])
132 OSSH_CHECK_CFLAG_COMPILE([-Wall]) 136 OSSH_CHECK_CFLAG_COMPILE([-Wall])
133 OSSH_CHECK_CFLAG_COMPILE([-Wpointer-arith]) 137 OSSH_CHECK_CFLAG_COMPILE([-Wpointer-arith])
134 OSSH_CHECK_CFLAG_COMPILE([-Wuninitialized]) 138 OSSH_CHECK_CFLAG_COMPILE([-Wuninitialized])
135 OSSH_CHECK_CFLAG_COMPILE([-Wsign-compare]) 139 OSSH_CHECK_CFLAG_COMPILE([-Wsign-compare])
136 OSSH_CHECK_CFLAG_COMPILE([-Wformat-security]) 140 OSSH_CHECK_CFLAG_COMPILE([-Wformat-security])
141 OSSH_CHECK_CFLAG_COMPILE([-Wsizeof-pointer-memaccess])
137 OSSH_CHECK_CFLAG_COMPILE([-Wpointer-sign], [-Wno-pointer-sign]) 142 OSSH_CHECK_CFLAG_COMPILE([-Wpointer-sign], [-Wno-pointer-sign])
138 OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result]) 143 OSSH_CHECK_CFLAG_COMPILE([-Wunused-result], [-Wno-unused-result])
139 OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing]) 144 OSSH_CHECK_CFLAG_COMPILE([-fno-strict-aliasing])
@@ -305,6 +310,7 @@ AC_CHECK_HEADERS([ \
305 ia.h \ 310 ia.h \
306 iaf.h \ 311 iaf.h \
307 limits.h \ 312 limits.h \
313 locale.h \
308 login.h \ 314 login.h \
309 maillock.h \ 315 maillock.h \
310 ndir.h \ 316 ndir.h \
@@ -343,7 +349,6 @@ AC_CHECK_HEADERS([ \
343 sys/sysmacros.h \ 349 sys/sysmacros.h \
344 sys/time.h \ 350 sys/time.h \
345 sys/timers.h \ 351 sys/timers.h \
346 sys/un.h \
347 time.h \ 352 time.h \
348 tmpdir.h \ 353 tmpdir.h \
349 ttyent.h \ 354 ttyent.h \
@@ -381,6 +386,12 @@ AC_CHECK_HEADERS([sys/mount.h], [], [], [
381#include <sys/param.h> 386#include <sys/param.h>
382]) 387])
383 388
389# Android requires sys/socket.h to be included before sys/un.h
390AC_CHECK_HEADERS([sys/un.h], [], [], [
391#include <sys/types.h>
392#include <sys/socket.h>
393])
394
384# Messages for features tested for in target-specific section 395# Messages for features tested for in target-specific section
385SIA_MSG="no" 396SIA_MSG="no"
386SPC_MSG="no" 397SPC_MSG="no"
@@ -482,6 +493,10 @@ case "$host" in
482 AC_DEFINE([PTY_ZEROREAD], [1], [read(1) can return 0 for a non-closed fd]) 493 AC_DEFINE([PTY_ZEROREAD], [1], [read(1) can return 0 for a non-closed fd])
483 AC_DEFINE([PLATFORM_SYS_DIR_UID], 2, [System dirs owned by bin (uid 2)]) 494 AC_DEFINE([PLATFORM_SYS_DIR_UID], 2, [System dirs owned by bin (uid 2)])
484 ;; 495 ;;
496*-*-android*)
497 AC_DEFINE([DISABLE_UTMP], [1], [Define if you don't want to use utmp])
498 AC_DEFINE([DISABLE_WTMP], [1], [Define if you don't want to use wtmp])
499 ;;
485*-*-cygwin*) 500*-*-cygwin*)
486 check_for_libcrypt_later=1 501 check_for_libcrypt_later=1
487 LIBS="$LIBS /usr/lib/textreadmode.o" 502 LIBS="$LIBS /usr/lib/textreadmode.o"
@@ -823,6 +838,7 @@ mips-sony-bsd|mips-sony-newsos4)
823 SP_MSG="yes" ], ) 838 SP_MSG="yes" ], )
824 ], 839 ],
825 ) 840 )
841 TEST_SHELL=$SHELL # let configure find us a capable shell
826 ;; 842 ;;
827*-*-sunos4*) 843*-*-sunos4*)
828 CPPFLAGS="$CPPFLAGS -DSUNOS4" 844 CPPFLAGS="$CPPFLAGS -DSUNOS4"
@@ -866,6 +882,7 @@ mips-sony-bsd|mips-sony-newsos4)
866 AC_DEFINE([BROKEN_SETREGID]) 882 AC_DEFINE([BROKEN_SETREGID])
867 AC_DEFINE([PASSWD_NEEDS_USERNAME], [1], [must supply username to passwd]) 883 AC_DEFINE([PASSWD_NEEDS_USERNAME], [1], [must supply username to passwd])
868 AC_DEFINE([LOCKED_PASSWD_STRING], ["*LK*"]) 884 AC_DEFINE([LOCKED_PASSWD_STRING], ["*LK*"])
885 TEST_SHELL=$SHELL # let configure find us a capable shell
869 ;; 886 ;;
870# UnixWare 7.x, OpenUNIX 8 887# UnixWare 7.x, OpenUNIX 8
871*-*-sysv5*) 888*-*-sysv5*)
@@ -877,10 +894,10 @@ mips-sony-bsd|mips-sony-newsos4)
877 AC_DEFINE([BROKEN_SETREUID]) 894 AC_DEFINE([BROKEN_SETREUID])
878 AC_DEFINE([BROKEN_SETREGID]) 895 AC_DEFINE([BROKEN_SETREGID])
879 AC_DEFINE([PASSWD_NEEDS_USERNAME]) 896 AC_DEFINE([PASSWD_NEEDS_USERNAME])
897 TEST_SHELL=$SHELL # let configure find us a capable shell
880 case "$host" in 898 case "$host" in
881 *-*-sysv5SCO_SV*) # SCO OpenServer 6.x 899 *-*-sysv5SCO_SV*) # SCO OpenServer 6.x
882 maildir=/var/spool/mail 900 maildir=/var/spool/mail
883 TEST_SHELL=/u95/bin/sh
884 AC_DEFINE([BROKEN_LIBIAF], [1], 901 AC_DEFINE([BROKEN_LIBIAF], [1],
885 [ia_uinfo routines not supported by OS yet]) 902 [ia_uinfo routines not supported by OS yet])
886 AC_DEFINE([BROKEN_UPDWTMPX]) 903 AC_DEFINE([BROKEN_UPDWTMPX])
@@ -921,7 +938,7 @@ mips-sony-bsd|mips-sony-newsos4)
921 AC_DEFINE([PASSWD_NEEDS_USERNAME]) 938 AC_DEFINE([PASSWD_NEEDS_USERNAME])
922 AC_CHECK_FUNCS([getluid setluid]) 939 AC_CHECK_FUNCS([getluid setluid])
923 MANTYPE=man 940 MANTYPE=man
924 TEST_SHELL=ksh 941 TEST_SHELL=$SHELL # let configure find us a capable shell
925 SKIP_DISABLE_LASTLOG_DEFINE=yes 942 SKIP_DISABLE_LASTLOG_DEFINE=yes
926 ;; 943 ;;
927*-*-unicosmk*) 944*-*-unicosmk*)
@@ -998,9 +1015,6 @@ mips-sony-bsd|mips-sony-newsos4)
998*-*-nto-qnx*) 1015*-*-nto-qnx*)
999 AC_DEFINE([USE_PIPES]) 1016 AC_DEFINE([USE_PIPES])
1000 AC_DEFINE([NO_X11_UNIX_SOCKETS]) 1017 AC_DEFINE([NO_X11_UNIX_SOCKETS])
1001 AC_DEFINE([MISSING_NFDBITS], [1], [Define on *nto-qnx systems])
1002 AC_DEFINE([MISSING_HOWMANY], [1], [Define on *nto-qnx systems])
1003 AC_DEFINE([MISSING_FD_MASK], [1], [Define on *nto-qnx systems])
1004 AC_DEFINE([DISABLE_LASTLOG]) 1018 AC_DEFINE([DISABLE_LASTLOG])
1005 AC_DEFINE([SSHD_ACQUIRES_CTTY]) 1019 AC_DEFINE([SSHD_ACQUIRES_CTTY])
1006 AC_DEFINE([BROKEN_SHADOW_EXPIRE], [1], [QNX shadow support is broken]) 1020 AC_DEFINE([BROKEN_SHADOW_EXPIRE], [1], [QNX shadow support is broken])
@@ -1021,7 +1035,6 @@ mips-sony-bsd|mips-sony-newsos4)
1021 1035
1022*-*-lynxos) 1036*-*-lynxos)
1023 CFLAGS="$CFLAGS -D__NO_INCLUDE_WARN__" 1037 CFLAGS="$CFLAGS -D__NO_INCLUDE_WARN__"
1024 AC_DEFINE([MISSING_HOWMANY])
1025 AC_DEFINE([BROKEN_SETVBUF], [1], [LynxOS has broken setvbuf() implementation]) 1038 AC_DEFINE([BROKEN_SETVBUF], [1], [LynxOS has broken setvbuf() implementation])
1026 ;; 1039 ;;
1027esac 1040esac
@@ -1144,6 +1157,7 @@ AC_ARG_WITH([zlib-version-check],
1144AC_MSG_CHECKING([for possibly buggy zlib]) 1157AC_MSG_CHECKING([for possibly buggy zlib])
1145AC_RUN_IFELSE([AC_LANG_PROGRAM([[ 1158AC_RUN_IFELSE([AC_LANG_PROGRAM([[
1146#include <stdio.h> 1159#include <stdio.h>
1160#include <stdlib.h>
1147#include <zlib.h> 1161#include <zlib.h>
1148 ]], 1162 ]],
1149 [[ 1163 [[
@@ -1193,12 +1207,13 @@ AC_CHECK_FUNCS([utimes],
1193dnl Checks for libutil functions 1207dnl Checks for libutil functions
1194AC_CHECK_HEADERS([bsd/libutil.h libutil.h]) 1208AC_CHECK_HEADERS([bsd/libutil.h libutil.h])
1195AC_SEARCH_LIBS([fmt_scaled], [util bsd]) 1209AC_SEARCH_LIBS([fmt_scaled], [util bsd])
1210AC_SEARCH_LIBS([scan_scaled], [util bsd])
1196AC_SEARCH_LIBS([login], [util bsd]) 1211AC_SEARCH_LIBS([login], [util bsd])
1197AC_SEARCH_LIBS([logout], [util bsd]) 1212AC_SEARCH_LIBS([logout], [util bsd])
1198AC_SEARCH_LIBS([logwtmp], [util bsd]) 1213AC_SEARCH_LIBS([logwtmp], [util bsd])
1199AC_SEARCH_LIBS([openpty], [util bsd]) 1214AC_SEARCH_LIBS([openpty], [util bsd])
1200AC_SEARCH_LIBS([updwtmp], [util bsd]) 1215AC_SEARCH_LIBS([updwtmp], [util bsd])
1201AC_CHECK_FUNCS([fmt_scaled login logout openpty updwtmp logwtmp]) 1216AC_CHECK_FUNCS([fmt_scaled scan_scaled login logout openpty updwtmp logwtmp])
1202 1217
1203AC_FUNC_STRFTIME 1218AC_FUNC_STRFTIME
1204 1219
@@ -1548,6 +1563,7 @@ AC_CHECK_FUNCS([ \
1548 clock \ 1563 clock \
1549 closefrom \ 1564 closefrom \
1550 dirfd \ 1565 dirfd \
1566 endgrent \
1551 fchmod \ 1567 fchmod \
1552 fchown \ 1568 fchown \
1553 freeaddrinfo \ 1569 freeaddrinfo \
@@ -1572,6 +1588,7 @@ AC_CHECK_FUNCS([ \
1572 inet_ntop \ 1588 inet_ntop \
1573 innetgr \ 1589 innetgr \
1574 login_getcapbool \ 1590 login_getcapbool \
1591 mblen \
1575 md5_crypt \ 1592 md5_crypt \
1576 memmove \ 1593 memmove \
1577 mkdtemp \ 1594 mkdtemp \
@@ -1668,6 +1685,9 @@ const char *gai_strerror(int);
1668AC_SEARCH_LIBS([nanosleep], [rt posix4], [AC_DEFINE([HAVE_NANOSLEEP], [1], 1685AC_SEARCH_LIBS([nanosleep], [rt posix4], [AC_DEFINE([HAVE_NANOSLEEP], [1],
1669 [Some systems put nanosleep outside of libc])]) 1686 [Some systems put nanosleep outside of libc])])
1670 1687
1688AC_SEARCH_LIBS([clock_gettime], [rt],
1689 [AC_DEFINE([HAVE_CLOCK_GETTIME], [1], [Have clock_gettime])])
1690
1671dnl Make sure prototypes are defined for these before using them. 1691dnl Make sure prototypes are defined for these before using them.
1672AC_CHECK_DECL([getrusage], [AC_CHECK_FUNCS([getrusage])]) 1692AC_CHECK_DECL([getrusage], [AC_CHECK_FUNCS([getrusage])])
1673AC_CHECK_DECL([strsep], 1693AC_CHECK_DECL([strsep],
@@ -1719,6 +1739,37 @@ AC_CHECK_DECLS([offsetof], , , [
1719#include <stddef.h> 1739#include <stddef.h>
1720 ]) 1740 ])
1721 1741
1742# extra bits for select(2)
1743AC_CHECK_DECLS([howmany, NFDBITS], [], [], [[
1744#include <sys/param.h>
1745#include <sys/types.h>
1746#ifdef HAVE_SYS_SYSMACROS_H
1747#include <sys/sysmacros.h>
1748#endif
1749#ifdef HAVE_SYS_SELECT_H
1750#include <sys/select.h>
1751#endif
1752#ifdef HAVE_SYS_TIME_H
1753#include <sys/time.h>
1754#endif
1755#ifdef HAVE_UNISTD_H
1756#include <unistd.h>
1757#endif
1758 ]])
1759AC_CHECK_TYPES([fd_mask], [], [], [[
1760#include <sys/param.h>
1761#include <sys/types.h>
1762#ifdef HAVE_SYS_SELECT_H
1763#include <sys/select.h>
1764#endif
1765#ifdef HAVE_SYS_TIME_H
1766#include <sys/time.h>
1767#endif
1768#ifdef HAVE_UNISTD_H
1769#include <unistd.h>
1770#endif
1771 ]])
1772
1722AC_CHECK_FUNCS([setresuid], [ 1773AC_CHECK_FUNCS([setresuid], [
1723 dnl Some platorms have setresuid that isn't implemented, test for this 1774 dnl Some platorms have setresuid that isn't implemented, test for this
1724 AC_MSG_CHECKING([if setresuid seems to work]) 1775 AC_MSG_CHECKING([if setresuid seems to work])
@@ -2367,6 +2418,8 @@ AC_LINK_IFELSE(
2367 ], 2418 ],
2368 [ 2419 [
2369 AC_MSG_RESULT([no]) 2420 AC_MSG_RESULT([no])
2421 unsupported_algorithms="$unsupported_cipers \
2422 aes128-gcm@openssh.com aes256-gcm@openssh.com"
2370 ] 2423 ]
2371) 2424)
2372 2425
@@ -2404,10 +2457,18 @@ fi
2404if test "x$check_for_libcrypt_later" = "x1"; then 2457if test "x$check_for_libcrypt_later" = "x1"; then
2405 AC_CHECK_LIB([crypt], [crypt], [LIBS="$LIBS -lcrypt"]) 2458 AC_CHECK_LIB([crypt], [crypt], [LIBS="$LIBS -lcrypt"])
2406fi 2459fi
2460AC_CHECK_FUNCS([crypt DES_crypt])
2407 2461
2408# Search for SHA256 support in libc and/or OpenSSL 2462# Search for SHA256 support in libc and/or OpenSSL
2409AC_CHECK_FUNCS([SHA256_Update EVP_sha256], [TEST_SSH_SHA256=yes], 2463AC_CHECK_FUNCS([SHA256_Update EVP_sha256],
2410 [TEST_SSH_SHA256=no]) 2464 [TEST_SSH_SHA256=yes],
2465 [TEST_SSH_SHA256=no
2466 unsupported_algorithms="$unsupported_algorithms \
2467 hmac-sha2-256 hmac-sha2-512 \
2468 diffie-hellman-group-exchange-sha256 \
2469 hmac-sha2-256-etm@openssh.com hmac-sha2-512-etm@openssh.com"
2470 ]
2471)
2411AC_SUBST([TEST_SSH_SHA256]) 2472AC_SUBST([TEST_SSH_SHA256])
2412 2473
2413# Check complete ECC support in OpenSSL 2474# Check complete ECC support in OpenSSL
@@ -2438,6 +2499,12 @@ AC_LINK_IFELSE(
2438 AC_MSG_RESULT([no]) 2499 AC_MSG_RESULT([no])
2439 TEST_SSH_ECC=no 2500 TEST_SSH_ECC=no
2440 COMMENT_OUT_ECC="#no ecc#" 2501 COMMENT_OUT_ECC="#no ecc#"
2502 unsupported_algorithms="$unsupported_algorithms \
2503 ecdh-sha2-nistp256 ecdh-sha2-nistp384 ecdh-sha2-nistp521 \
2504 ecdsa-sha2-nistp256-cert-v01@openssh.com \
2505 ecdsa-sha2-nistp384-cert-v01@openssh.com \
2506 ecdsa-sha2-nistp521-cert-v01@openssh.com \
2507 ecdsa-sha2-nistp256 ecdsa-sha2-nistp384 ecdsa-sha2-nistp521"
2441 ] 2508 ]
2442) 2509)
2443AC_SUBST([TEST_SSH_ECC]) 2510AC_SUBST([TEST_SSH_ECC])
@@ -3325,9 +3392,16 @@ OSSH_CHECK_HEADER_FOR_FIELD([ut_time], [utmpx.h], [HAVE_TIME_IN_UTMPX])
3325OSSH_CHECK_HEADER_FOR_FIELD([ut_tv], [utmpx.h], [HAVE_TV_IN_UTMPX]) 3392OSSH_CHECK_HEADER_FOR_FIELD([ut_tv], [utmpx.h], [HAVE_TV_IN_UTMPX])
3326 3393
3327AC_CHECK_MEMBERS([struct stat.st_blksize]) 3394AC_CHECK_MEMBERS([struct stat.st_blksize])
3395AC_CHECK_MEMBERS([struct passwd.pw_gecos, struct passwd.pw_class,
3396struct passwd.pw_change, struct passwd.pw_expire],
3397[], [], [[
3398#include <sys/types.h>
3399#include <pwd.h>
3400]])
3401
3328AC_CHECK_MEMBER([struct __res_state.retrans], [], [AC_DEFINE([__res_state], [state], 3402AC_CHECK_MEMBER([struct __res_state.retrans], [], [AC_DEFINE([__res_state], [state],
3329 [Define if we don't have struct __res_state in resolv.h])], 3403 [Define if we don't have struct __res_state in resolv.h])],
3330[ 3404[[
3331#include <stdio.h> 3405#include <stdio.h>
3332#if HAVE_SYS_TYPES_H 3406#if HAVE_SYS_TYPES_H
3333# include <sys/types.h> 3407# include <sys/types.h>
@@ -3335,7 +3409,7 @@ AC_CHECK_MEMBER([struct __res_state.retrans], [], [AC_DEFINE([__res_state], [sta
3335#include <netinet/in.h> 3409#include <netinet/in.h>
3336#include <arpa/nameser.h> 3410#include <arpa/nameser.h>
3337#include <resolv.h> 3411#include <resolv.h>
3338]) 3412]])
3339 3413
3340AC_CACHE_CHECK([for ss_family field in struct sockaddr_storage], 3414AC_CACHE_CHECK([for ss_family field in struct sockaddr_storage],
3341 ac_cv_have_ss_family_in_struct_ss, [ 3415 ac_cv_have_ss_family_in_struct_ss, [
@@ -3365,45 +3439,6 @@ if test "x$ac_cv_have___ss_family_in_struct_ss" = "xyes" ; then
3365 [Fields in struct sockaddr_storage]) 3439 [Fields in struct sockaddr_storage])
3366fi 3440fi
3367 3441
3368AC_CACHE_CHECK([for pw_class field in struct passwd],
3369 ac_cv_have_pw_class_in_struct_passwd, [
3370 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <pwd.h> ]],
3371 [[ struct passwd p; p.pw_class = 0; ]])],
3372 [ ac_cv_have_pw_class_in_struct_passwd="yes" ],
3373 [ ac_cv_have_pw_class_in_struct_passwd="no"
3374 ])
3375])
3376if test "x$ac_cv_have_pw_class_in_struct_passwd" = "xyes" ; then
3377 AC_DEFINE([HAVE_PW_CLASS_IN_PASSWD], [1],
3378 [Define if your password has a pw_class field])
3379fi
3380
3381AC_CACHE_CHECK([for pw_expire field in struct passwd],
3382 ac_cv_have_pw_expire_in_struct_passwd, [
3383 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <pwd.h> ]],
3384 [[ struct passwd p; p.pw_expire = 0; ]])],
3385 [ ac_cv_have_pw_expire_in_struct_passwd="yes" ],
3386 [ ac_cv_have_pw_expire_in_struct_passwd="no"
3387 ])
3388])
3389if test "x$ac_cv_have_pw_expire_in_struct_passwd" = "xyes" ; then
3390 AC_DEFINE([HAVE_PW_EXPIRE_IN_PASSWD], [1],
3391 [Define if your password has a pw_expire field])
3392fi
3393
3394AC_CACHE_CHECK([for pw_change field in struct passwd],
3395 ac_cv_have_pw_change_in_struct_passwd, [
3396 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <pwd.h> ]],
3397 [[ struct passwd p; p.pw_change = 0; ]])],
3398 [ ac_cv_have_pw_change_in_struct_passwd="yes" ],
3399 [ ac_cv_have_pw_change_in_struct_passwd="no"
3400 ])
3401])
3402if test "x$ac_cv_have_pw_change_in_struct_passwd" = "xyes" ; then
3403 AC_DEFINE([HAVE_PW_CHANGE_IN_PASSWD], [1],
3404 [Define if your password has a pw_change field])
3405fi
3406
3407dnl make sure we're using the real structure members and not defines 3442dnl make sure we're using the real structure members and not defines
3408AC_CACHE_CHECK([for msg_accrights field in struct msghdr], 3443AC_CACHE_CHECK([for msg_accrights field in struct msghdr],
3409 ac_cv_have_accrights_in_msghdr, [ 3444 ac_cv_have_accrights_in_msghdr, [
@@ -3795,6 +3830,11 @@ AC_ARG_WITH([kerberos5],
3795# include <gssapi/gssapi_generic.h> 3830# include <gssapi/gssapi_generic.h>
3796#endif 3831#endif
3797 ]]) 3832 ]])
3833 saved_LIBS="$LIBS"
3834 LIBS="$LIBS $K5LIBS"
3835 AC_CHECK_FUNCS([krb5_cc_new_unique krb5_get_error_message krb5_free_error_message])
3836 LIBS="$saved_LIBS"
3837
3798 fi 3838 fi
3799 ] 3839 ]
3800) 3840)
@@ -4569,6 +4609,7 @@ else
4569fi 4609fi
4570AC_CHECK_DECL([BROKEN_GETADDRINFO], [TEST_SSH_IPV6=no]) 4610AC_CHECK_DECL([BROKEN_GETADDRINFO], [TEST_SSH_IPV6=no])
4571AC_SUBST([TEST_SSH_IPV6], [$TEST_SSH_IPV6]) 4611AC_SUBST([TEST_SSH_IPV6], [$TEST_SSH_IPV6])
4612AC_SUBST([UNSUPPORTED_ALGORITHMS], [$unsupported_algorithms])
4572 4613
4573AC_EXEEXT 4614AC_EXEEXT
4574AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \ 4615AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \