summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@dtucker.net>2019-11-15 18:56:54 +1100
committerDarren Tucker <dtucker@dtucker.net>2019-11-15 18:56:54 +1100
commit39b87104cdd47baf79ef77dc81de62cea07d119f (patch)
treeb5620074868fbcec1f0b346635bdf4cc49eb2b25 /configure.ac
parent134a74f4e0cf750931f1125beb2a3f40c54c8809 (diff)
Add wrappers for other ultrix headers.
Wrappers protect against multiple inclusions for headers that don't do it themselves.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 99a88d6d9..cc944174b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,17 +1207,19 @@ mips-sony-bsd|mips-sony-newsos4)
1207 # DISABLE_FD_PASSING so that we call setpgrp as root, otherwise we 1207 # DISABLE_FD_PASSING so that we call setpgrp as root, otherwise we
1208 # don't get a controlling tty. 1208 # don't get a controlling tty.
1209 AC_DEFINE([DISABLE_FD_PASSING], [1], [Need to call setpgrp as root]) 1209 AC_DEFINE([DISABLE_FD_PASSING], [1], [Need to call setpgrp as root])
1210 # On Ultrix netinet/ip.h is not protected against multiple includes, 1210 # On Ultrix some headers are not protected against multiple includes,
1211 # so we create our own wrapper and put it where the compiler will 1211 # so we create wrappers and put it where the compiler will find it.
1212 # find it. 1212 AC_MSG_WARN([creating compat wrappers for headers])
1213 AC_MSG_WARN([creating compat wrapper for netinet/ip.h])
1214 mkdir -p netinet 1213 mkdir -p netinet
1215 cat >netinet/ip.h <<EOD 1214 for header in netinet/ip.h netdb.h resolv.h; do
1216#ifndef _SSH_COMPAT_NETINET_IP_H 1215 name=`echo $header | tr 'a-z/.' 'A-Z__'`
1217#define _SSH_COMPAT_NETINET_IP_H 1216 cat >$header <<EOD
1218#include "/usr/include/netinet/ip.h" 1217#ifndef _SSH_COMPAT_${name}
1218#define _SSH_COMPAT_${name}
1219#include "/usr/include/${header}"
1219#endif 1220#endif
1220EOD 1221EOD
1222 done
1221 ;; 1223 ;;
1222 1224
1223*-*-lynxos) 1225*-*-lynxos)