summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2005-08-23 17:11:26 -0700
committerTim Rice <tim@multitalents.net>2005-08-23 17:11:26 -0700
commit3db1e3fc685cb0c570b4e17a60e0e041fa48b32f (patch)
tree5fa4583ce7748e6a064ad5e4dbf171eacee55628 /configure.ac
parent114572f7ee4acd2aab331784f658851e5fbad9a4 (diff)
- (tim) [configure.ac ] Not all gcc's support -Wsign-compare
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 619a4e76a..f1588c693 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.287 2005/08/22 22:06:56 dtucker Exp $ 1# $Id: configure.ac,v 1.288 2005/08/24 00:11:26 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -82,7 +82,13 @@ AC_CHECK_DECL(LLONG_MAX, have_llong_max=1, , [#include <limits.h>])
82 82
83if test "$GCC" = "yes" || test "$GCC" = "egcs"; then 83if test "$GCC" = "yes" || test "$GCC" = "egcs"; then
84 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wuninitialized" 84 CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wuninitialized"
85 CFLAGS="$CFLAGS -Wsign-compare" 85 GCC_VER=`$CC --version`
86 case $GCC_VER in
87 1.*) ;;
88 2.8* | 2.9*) CFLAGS="$CFLAGS -Wsign-compare" ;;
89 2.*) ;;
90 *) CFLAGS="$CFLAGS -Wsign-compare" ;;
91 esac
86 92
87 if test -z "$have_llong_max"; then 93 if test -z "$have_llong_max"; then
88 # retry LLONG_MAX with -std=gnu99, needed on some Linuxes 94 # retry LLONG_MAX with -std=gnu99, needed on some Linuxes