summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-06-17 12:44:30 +0000
committerColin Watson <cjwatson@debian.org>2005-06-17 12:44:30 +0000
commit4c2d1c67cea075107aadaa6d81fe456687c69e67 (patch)
tree4f31813c8306491c908948bd75254912385ed651 /configure.ac
parentbed4bb0fe9380912ecb90e5f918bce8825ec0a38 (diff)
Manoj Srivastava:
- Added SELinux capability, and turned it on be default. Added restorecon calls in preinst and postinst (should not matter if the machine is not SELinux aware). By and large, the changes made should have no effect unless the rules file calls --with-selinux; and even then there should be no performance hit for machines not actively running SELinux. - Modified the preinst and postinst to call restorecon to set the security context for the generated public key files. - Added a comment to /etc/pam.d/ssh to indicate that an SELinux system may want to also include pam_selinux.so.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20c8f1587..b938228c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2407,6 +2407,18 @@ int main()
2407 [#include <arpa/nameser.h>]) 2407 [#include <arpa/nameser.h>])
2408 ]) 2408 ])
2409 2409
2410# Check whether user wants SELinux support
2411SELINUX_MSG="no"
2412AC_ARG_WITH(selinux,
2413 [ --with-selinux Enable SELinux support],
2414 [ if test "x$withval" != "xno" ; then
2415 AC_DEFINE(WITH_SELINUX, 1, [Define if you want SELinux support.])
2416 SELINUX_MSG="yes"
2417 AC_CHECK_HEADERS(selinux/selinux.h)
2418 LIBS="$LIBS -lselinux"
2419 fi
2420 ])
2421
2410# Check whether user wants Kerberos 5 support 2422# Check whether user wants Kerberos 5 support
2411KRB5_MSG="no" 2423KRB5_MSG="no"
2412AC_ARG_WITH(kerberos5, 2424AC_ARG_WITH(kerberos5,
@@ -3188,6 +3200,7 @@ fi
3188echo " Manpage format: $MANTYPE" 3200echo " Manpage format: $MANTYPE"
3189echo " PAM support: $PAM_MSG" 3201echo " PAM support: $PAM_MSG"
3190echo " KerberosV support: $KRB5_MSG" 3202echo " KerberosV support: $KRB5_MSG"
3203echo " SELinux support: $SELINUX_MSG"
3191echo " Smartcard support: $SCARD_MSG" 3204echo " Smartcard support: $SCARD_MSG"
3192echo " S/KEY support: $SKEY_MSG" 3205echo " S/KEY support: $SKEY_MSG"
3193echo " TCP Wrappers support: $TCPW_MSG" 3206echo " TCP Wrappers support: $TCPW_MSG"