summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2019-11-15 16:08:00 +1100
committerDamien Miller <djm@mindrot.org>2019-11-15 16:08:00 +1100
commit5c0bc273cba53f822b7d777bbb6c35d160d3b505 (patch)
tree340c42b651825967f70391987c05558c35f2c01e /configure.ac
parentfbcb9a7fa55300b8bd4c18bee024c6104c5a25d7 (diff)
configure flag to built-in security key support
Require --with-security-key-builtin before enabling the built-in security key support (and consequent dependency on libfido2).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3814db66b..0c2882b1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1908,6 +1908,16 @@ AC_ARG_ENABLE([security-key],
1908 fi 1908 fi
1909 ] 1909 ]
1910) 1910)
1911enable_sk_internal=
1912AC_ARG_WITH([security-key-builtin],
1913 [ --with-security-key-builtin include builtin U2F/FIDO support],
1914 [
1915 if test "x$withval" != "xno" ; then
1916 enable_sk_internal=yes
1917 fi
1918 ]
1919)
1920test "x$disable_sk" != "x" && enable_sk_internal=""
1911 1921
1912AC_SEARCH_LIBS([dlopen], [dl]) 1922AC_SEARCH_LIBS([dlopen], [dl])
1913AC_CHECK_FUNCS([dlopen]) 1923AC_CHECK_FUNCS([dlopen])
@@ -3062,7 +3072,7 @@ fi
3062AC_MSG_RESULT([$enable_sk]) 3072AC_MSG_RESULT([$enable_sk])
3063 3073
3064# Now check for built-in security key support. 3074# Now check for built-in security key support.
3065if test "x$enable_sk" = "xyes" ; then 3075if test "x$enable_sk" = "xyes" -a "x$enable_sk_internal" = "xyes" ; then
3066 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no]) 3076 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
3067 use_pkgconfig_for_libfido2= 3077 use_pkgconfig_for_libfido2=
3068 if test "x$PKGCONFIG" != "xno"; then 3078 if test "x$PKGCONFIG" != "xno"; then