summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2013-02-07 10:11:05 +1100
committerDamien Miller <djm@mindrot.org>2013-02-07 10:11:05 +1100
commit5c3bbd76aa5c6f050e7b4606ea55efce3d46e054 (patch)
treecd3ad55d5ed2f6e629b7e25f4924305dbfc9fad3 /configure.ac
parentdc75d1fc0488a6637779470200f2b4dca2ed6248 (diff)
- (djm) [configure.ac] Don't probe seccomp capability of running kernel
at configure time; the seccomp sandbox will fall back to rlimit at runtime anyway. Patch from plautrba AT redhat.com in bz#2011
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 36761233c..f61106441 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.500 2013/01/09 05:42:47 djm Exp $ 1# $Id: configure.ac,v 1.501 2013/02/06 23:11:05 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.500 $) 18AC_REVISION($Revision: 1.501 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -128,7 +128,7 @@ AC_CHECK_DECL([SECCOMP_MODE_FILTER], [have_seccomp_filter=1], , [
128fi 128fi
129if test "x$have_seccomp_filter" = "x1" ; then 129if test "x$have_seccomp_filter" = "x1" ; then
130AC_MSG_CHECKING([kernel for seccomp_filter support]) 130AC_MSG_CHECKING([kernel for seccomp_filter support])
131AC_RUN_IFELSE([AC_LANG_PROGRAM([[ 131AC_LINK_IFELSE([AC_LANG_PROGRAM([[
132 #include <errno.h> 132 #include <errno.h>
133 #include <linux/seccomp.h> 133 #include <linux/seccomp.h>
134 #include <stdlib.h> 134 #include <stdlib.h>
@@ -141,8 +141,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([[
141 AC_MSG_RESULT([no]) 141 AC_MSG_RESULT([no])
142 # Disable seccomp filter as a target 142 # Disable seccomp filter as a target
143 have_seccomp_filter=0 143 have_seccomp_filter=0
144 ], 144 ]
145 [ AC_MSG_RESULT([cross-compiling, assuming yes]) ]
146) 145)
147fi 146fi
148 147