summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-08-02 22:24:49 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-08-02 22:24:49 +1000
commit6aaa58c4709c43ffb9f3f2be299cd5c4044f24a3 (patch)
treeecaaf1b076e187ff9e338c844547dec1be09e006 /configure.ac
parent4c29dd9f4438d2ab6ac8d2df361fd48360b208ab (diff)
- (dtucker) OpenBSD CVS Sync
- markus@cvs.openbsd.org 2003/07/22 13:35:22 [auth1.c auth.h auth-passwd.c monitor.c monitor.h monitor_wrap.c monitor_wrap.h readconf.c readconf.h servconf.c servconf.h session.c ssh.1 ssh.c ssh_config.5 sshconnect1.c sshd.c sshd_config.5 ssh.h] remove (already disabled) KRB4/AFS support, re-enable -k in ssh(1); test+ok henning@ - (dtucker) [Makefile.in acconfig.h configure.ac] Remove KRB4/AFS support. - (dtucker) [auth-krb4.c radix.c radix.h] Remove KRB4/AFS specific files. I hope I got this right....
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac87
1 files changed, 2 insertions, 85 deletions
diff --git a/configure.ac b/configure.ac
index 74909343d..68fa5c1f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.137 2003/07/23 04:33:10 dtucker Exp $ 1# $Id: configure.ac,v 1.138 2003/08/02 12:24:49 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -54,7 +54,6 @@ fi
54# Check for some target-specific stuff 54# Check for some target-specific stuff
55case "$host" in 55case "$host" in
56*-*-aix*) 56*-*-aix*)
57 AFS_LIBS="-lld"
58 CPPFLAGS="$CPPFLAGS -I/usr/local/include" 57 CPPFLAGS="$CPPFLAGS -I/usr/local/include"
59 LDFLAGS="$LDFLAGS -L/usr/local/lib" 58 LDFLAGS="$LDFLAGS -L/usr/local/lib"
60 AC_MSG_CHECKING([how to specify blibpath for linker ($LD)]) 59 AC_MSG_CHECKING([how to specify blibpath for linker ($LD)])
@@ -1940,87 +1939,7 @@ AC_ARG_WITH(kerberos5,
1940 fi 1939 fi
1941 ] 1940 ]
1942) 1941)
1943# Check whether user wants Kerberos 4 support 1942LIBS="$LIBS $K5LIBS"
1944KRB4_MSG="no"
1945AC_ARG_WITH(kerberos4,
1946 [ --with-kerberos4=PATH Enable Kerberos 4 support],
1947 [
1948 if test "x$withval" != "xno" ; then
1949 if test "x$withval" != "xyes" ; then
1950 CPPFLAGS="$CPPFLAGS -I${withval}/include"
1951 LDFLAGS="$LDFLAGS -L${withval}/lib"
1952 if test ! -z "$need_dash_r" ; then
1953 LDFLAGS="$LDFLAGS -R${withval}/lib"
1954 fi
1955 if test ! -z "$blibpath" ; then
1956 blibpath="$blibpath:${withval}/lib"
1957 fi
1958 else
1959 if test -d /usr/include/kerberosIV ; then
1960 CPPFLAGS="$CPPFLAGS -I/usr/include/kerberosIV"
1961 fi
1962 fi
1963
1964 AC_CHECK_HEADERS(krb.h)
1965 if test "$ac_cv_header_krb_h" != yes; then
1966 AC_MSG_WARN([Cannot find krb.h, build may fail])
1967 fi
1968 AC_CHECK_LIB(krb, main)
1969 if test "$ac_cv_lib_krb_main" != yes; then
1970 AC_CHECK_LIB(krb4, main)
1971 if test "$ac_cv_lib_krb4_main" != yes; then
1972 AC_MSG_WARN([Cannot find libkrb nor libkrb4, build may fail])
1973 else
1974 KLIBS="-lkrb4"
1975 fi
1976 else
1977 KLIBS="-lkrb"
1978 fi
1979 AC_CHECK_LIB(des, des_cbc_encrypt)
1980 if test "$ac_cv_lib_des_des_cbc_encrypt" != yes; then
1981 AC_CHECK_LIB(des425, des_cbc_encrypt)
1982 if test "$ac_cv_lib_des425_des_cbc_encrypt" != yes; then
1983 AC_MSG_WARN([Cannot find libdes nor libdes425, build may fail])
1984 else
1985 KLIBS="-ldes425"
1986 fi
1987 else
1988 KLIBS="-ldes"
1989 fi
1990 AC_CHECK_LIB(resolv, dn_expand, , )
1991 KRB4=yes
1992 KRB4_MSG="yes"
1993 AC_DEFINE(KRB4)
1994 fi
1995 ]
1996)
1997
1998# Check whether user wants AFS support
1999AFS_MSG="no"
2000AC_ARG_WITH(afs,
2001 [ --with-afs=PATH Enable AFS support],
2002 [
2003 if test "x$withval" != "xno" ; then
2004
2005 if test "x$withval" != "xyes" ; then
2006 CPPFLAGS="$CPPFLAGS -I${withval}/include"
2007 LDFLAGS="$LDFLAGS -L${withval}/lib"
2008 fi
2009
2010 if test -z "$KRB4" ; then
2011 AC_MSG_WARN([AFS requires Kerberos IV support, build may fail])
2012 fi
2013
2014 LIBS="-lkafs $LIBS"
2015 if test ! -z "$AFS_LIBS" ; then
2016 LIBS="$LIBS $AFS_LIBS"
2017 fi
2018 AC_DEFINE(AFS)
2019 AFS_MSG="yes"
2020 fi
2021 ]
2022)
2023LIBS="$LIBS $KLIBS $K5LIBS"
2024 1943
2025# Looking for programs, paths and files 1944# Looking for programs, paths and files
2026 1945
@@ -2648,10 +2567,8 @@ fi
2648echo " Manpage format: $MANTYPE" 2567echo " Manpage format: $MANTYPE"
2649echo " DNS support: $DNS_MSG" 2568echo " DNS support: $DNS_MSG"
2650echo " PAM support: $PAM_MSG" 2569echo " PAM support: $PAM_MSG"
2651echo " KerberosIV support: $KRB4_MSG"
2652echo " KerberosV support: $KRB5_MSG" 2570echo " KerberosV support: $KRB5_MSG"
2653echo " Smartcard support: $SCARD_MSG" 2571echo " Smartcard support: $SCARD_MSG"
2654echo " AFS support: $AFS_MSG"
2655echo " S/KEY support: $SKEY_MSG" 2572echo " S/KEY support: $SKEY_MSG"
2656echo " TCP Wrappers support: $TCPW_MSG" 2573echo " TCP Wrappers support: $TCPW_MSG"
2657echo " MD5 password support: $MD5_MSG" 2574echo " MD5 password support: $MD5_MSG"