summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-06-29 21:30:41 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-06-29 21:30:41 +1000
commit6eb9304782a7404fca406f742d4546e55c8dc1c7 (patch)
tree8ec48dd80c804ea3f77e7bd132074200e583ba14 /configure.ac
parentcc9fd54a3636d98dbada76f71bd5e6e82495f9c0 (diff)
- (dtucker) [configure.ac] Add sanity test after system-dependant compiler
flag modifications.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0992744c1..bf00443a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.128 2003/06/28 02:54:33 dtucker Exp $ 1# $Id: configure.ac,v 1.129 2003/06/29 11:30:41 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -438,6 +438,18 @@ AC_ARG_WITH(libs,
438 ] 438 ]
439) 439)
440 440
441AC_MSG_CHECKING(compiler and flags for sanity)
442AC_TRY_RUN([
443#include <stdio.h>
444int main(){exit(0);}
445 ],
446 [ AC_MSG_RESULT(yes) ],
447 [
448 AC_MSG_RESULT(no)
449 AC_MSG_ERROR([*** compiler cannot create working executables, check config.log ***])
450 ]
451)
452
441# Checks for header files. 453# Checks for header files.
442AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \ 454AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
443 getopt.h glob.h ia.h lastlog.h libgen.h limits.h login.h \ 455 getopt.h glob.h ia.h lastlog.h libgen.h limits.h login.h \