summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2014-02-09 16:09:57 +0000
committerColin Watson <cjwatson@debian.org>2014-03-20 00:32:21 +0000
commit7a26d16efb4ee303c8d66ee82caf9d0686f4a074 (patch)
tree131e8962617e1f41402ba2468ad331dd888c101a /configure.ac
parentef912859a4300360164292abe47b5516c8ee4a13 (diff)
Add support for registering ConsoleKit sessions on login
Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1450 Last-Updated: 2014-03-20 Patch-Name: consolekit.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d235fb06b..86692714b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4072,6 +4072,30 @@ AC_ARG_WITH([kerberos5],
4072AC_SUBST([GSSLIBS]) 4072AC_SUBST([GSSLIBS])
4073AC_SUBST([K5LIBS]) 4073AC_SUBST([K5LIBS])
4074 4074
4075# Check whether user wants ConsoleKit support
4076CONSOLEKIT_MSG="no"
4077LIBCK_CONNECTOR=""
4078AC_ARG_WITH(consolekit,
4079 [ --with-consolekit Enable ConsoleKit support],
4080 [ if test "x$withval" != "xno" ; then
4081 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4082 if test "$PKGCONFIG" != "no"; then
4083 AC_MSG_CHECKING([for ck-connector])
4084 if $PKGCONFIG --exists ck-connector; then
4085 CKCON_CFLAGS=`$PKGCONFIG --cflags ck-connector`
4086 CKCON_LIBS=`$PKGCONFIG --libs ck-connector`
4087 CPPFLAGS="$CPPFLAGS $CKCON_CFLAGS"
4088 SSHDLIBS="$SSHDLIBS $CKCON_LIBS"
4089 AC_MSG_RESULT([yes])
4090 AC_DEFINE(USE_CONSOLEKIT, 1, [Define if you want ConsoleKit support.])
4091 CONSOLEKIT_MSG="yes"
4092 else
4093 AC_MSG_RESULT([no])
4094 fi
4095 fi
4096 fi ]
4097)
4098
4075# Looking for programs, paths and files 4099# Looking for programs, paths and files
4076 4100
4077PRIVSEP_PATH=/var/empty 4101PRIVSEP_PATH=/var/empty
@@ -4873,6 +4897,7 @@ echo " MD5 password support: $MD5_MSG"
4873echo " libedit support: $LIBEDIT_MSG" 4897echo " libedit support: $LIBEDIT_MSG"
4874echo " Solaris process contract support: $SPC_MSG" 4898echo " Solaris process contract support: $SPC_MSG"
4875echo " Solaris project support: $SP_MSG" 4899echo " Solaris project support: $SP_MSG"
4900echo " ConsoleKit support: $CONSOLEKIT_MSG"
4876echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 4901echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
4877echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 4902echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
4878echo " BSD Auth support: $BSD_AUTH_MSG" 4903echo " BSD Auth support: $BSD_AUTH_MSG"