summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Wilkinson <simon@sxw.org.uk>2014-02-09 16:09:48 +0000
committerColin Watson <cjwatson@debian.org>2019-10-09 23:06:20 +0100
commit9da806e67101afdc0d3a1d304659927acf18f5c5 (patch)
tree4cb56e13b3b3b14147366a04a7ff691f76908bf7 /configure.ac
parent4213eec74e74de6310c27a40c3e9759a08a73996 (diff)
GSSAPI key exchange support
This patch has been rejected upstream: "None of the OpenSSH developers are in favour of adding this, and this situation has not changed for several years. This is not a slight on Simon's patch, which is of fine quality, but just that a) we don't trust GSSAPI implementations that much and b) we don't like adding new KEX since they are pre-auth attack surface. This one is particularly scary, since it requires hooks out to typically root-owned system resources." However, quite a lot of people rely on this in Debian, and it's better to have it merged into the main openssh package rather than having separate -krb5 packages (as we used to have). It seems to have a generally good security history. Origin: other, https://github.com/openssh-gsskex/openssh-gsskex/commits/debian/master Bug: https://bugzilla.mindrot.org/show_bug.cgi?id=1242 Last-Updated: 2019-10-09 Patch-Name: gssapi.patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e93c0276..1c2512314 100644
--- a/configure.ac
+++ b/configure.ac
@@ -666,6 +666,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
666 [Use tunnel device compatibility to OpenBSD]) 666 [Use tunnel device compatibility to OpenBSD])
667 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 667 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
668 [Prepend the address family to IP tunnel traffic]) 668 [Prepend the address family to IP tunnel traffic])
669 AC_MSG_CHECKING([if we have the Security Authorization Session API])
670 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
671 [SessionCreate(0, 0);],
672 [ac_cv_use_security_session_api="yes"
673 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
674 [platform has the Security Authorization Session API])
675 LIBS="$LIBS -framework Security"
676 AC_MSG_RESULT([yes])],
677 [ac_cv_use_security_session_api="no"
678 AC_MSG_RESULT([no])])
679 AC_MSG_CHECKING([if we have an in-memory credentials cache])
680 AC_TRY_COMPILE(
681 [#include <Kerberos/Kerberos.h>],
682 [cc_context_t c;
683 (void) cc_initialize (&c, 0, NULL, NULL);],
684 [AC_DEFINE([USE_CCAPI], [1],
685 [platform uses an in-memory credentials cache])
686 LIBS="$LIBS -framework Security"
687 AC_MSG_RESULT([yes])
688 if test "x$ac_cv_use_security_session_api" = "xno"; then
689 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
690 fi],
691 [AC_MSG_RESULT([no])]
692 )
669 m4_pattern_allow([AU_IPv]) 693 m4_pattern_allow([AU_IPv])
670 AC_CHECK_DECL([AU_IPv4], [], 694 AC_CHECK_DECL([AU_IPv4], [],
671 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 695 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])