summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2010-02-12 10:11:34 +1100
committerDamien Miller <djm@mindrot.org>2010-02-12 10:11:34 +1100
commitb3c9f78711bde96415d22046af2c0f8c071a7e6f (patch)
tree2d0ca346265264f2774a1b8f2c3e647d6e22f6e0 /configure.ac
parentdfa4156dbd4aa45464b2ea6b867bcaa483bed134 (diff)
- (djm) [configure.ac] Enable PKCS#11 support only when we find a working
dlopen()
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 40b58c64f..f4c25683c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.442 2010/02/11 22:34:22 djm Exp $ 1# $Id: configure.ac,v 1.443 2010/02/11 23:11:34 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.442 $) 18AC_REVISION($Revision: 1.443 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1420,6 +1420,11 @@ AC_CHECK_FUNCS( \
1420 waitpid \ 1420 waitpid \
1421) 1421)
1422 1422
1423# PKCS#11 support requires dlopen() and co
1424AC_SEARCH_LIBS(dlopen, dl,
1425 AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])
1426)
1427
1423# IRIX has a const char return value for gai_strerror() 1428# IRIX has a const char return value for gai_strerror()
1424AC_CHECK_FUNCS(gai_strerror,[ 1429AC_CHECK_FUNCS(gai_strerror,[
1425 AC_DEFINE(HAVE_GAI_STRERROR) 1430 AC_DEFINE(HAVE_GAI_STRERROR)
@@ -4130,10 +4135,6 @@ else
4130 AC_SUBST(TEST_SSH_IPV6, yes) 4135 AC_SUBST(TEST_SSH_IPV6, yes)
4131fi 4136fi
4132 4137
4133if test "x$enable_pkcs11" != "xno" ; then
4134 AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])
4135fi
4136
4137AC_EXEEXT 4138AC_EXEEXT
4138AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \ 4139AC_CONFIG_FILES([Makefile buildpkg.sh opensshd.init openssh.xml \
4139 openbsd-compat/Makefile openbsd-compat/regress/Makefile \ 4140 openbsd-compat/Makefile openbsd-compat/regress/Makefile \