summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2013-02-11 10:39:12 +1100
committerDamien Miller <djm@mindrot.org>2013-02-11 10:39:12 +1100
commitb6f73b3af6fa14df1306d763dd7ec38f68de6f79 (patch)
treef5f8780e1b63d379a66130e8e0db035deceecd6a /configure.ac
parent951b53b1bede98fdcfeeac8c5c00dbf3948d9b75 (diff)
- (djm) [configure.ac openbsd-compat/openssl-compat.h] Repair build on old
libcrypto that lacks EVP_CIPHER_CTX_ctrl
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6df09e210..e96e81e64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.502 2013/02/08 00:50:09 dtucker Exp $ 1# $Id: configure.ac,v 1.503 2013/02/10 23:39:13 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.502 $) 18AC_REVISION($Revision: 1.503 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2339,7 +2339,12 @@ AC_LINK_IFELSE(
2339#include <openssl/evp.h> 2339#include <openssl/evp.h>
2340 ]], [[ 2340 ]], [[
2341 exit(EVP_aes_128_gcm() == NULL || 2341 exit(EVP_aes_128_gcm() == NULL ||
2342 EVP_aes_256_gcm() == NULL); 2342 EVP_aes_256_gcm() == NULL ||
2343 EVP_CTRL_GCM_SET_IV_FIXED == 0 ||
2344 EVP_CTRL_GCM_IV_GEN == 0 ||
2345 EVP_CTRL_GCM_SET_TAG == 0 ||
2346 EVP_CTRL_GCM_GET_TAG == 0 ||
2347 EVP_CIPHER_CTX_ctrl(NULL, 0, 0, NULL) == 0);
2343 ]])], 2348 ]])],
2344 [ 2349 [
2345 AC_MSG_RESULT([yes]) 2350 AC_MSG_RESULT([yes])
@@ -2351,6 +2356,10 @@ AC_LINK_IFELSE(
2351 ] 2356 ]
2352) 2357)
2353 2358
2359AC_SEARCH_LIBS([EVP_CIPHER_CTX_ctrl], [crypto],
2360 [AC_DEFINE([HAVE_EVP_CIPHER_CTX_CTRL], [1],
2361 [Define if libcrypto has EVP_CIPHER_CTX_ctrl])])
2362
2354AC_MSG_CHECKING([if EVP_DigestUpdate returns an int]) 2363AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2355AC_LINK_IFELSE( 2364AC_LINK_IFELSE(
2356 [AC_LANG_PROGRAM([[ 2365 [AC_LANG_PROGRAM([[