summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2010-11-08 14:26:23 -0800
committerTim Rice <tim@multitalents.net>2010-11-08 14:26:23 -0800
commitc7a8af03a022e8ab52422b6ce26fdbcb729031fd (patch)
treefa4a41a93bb6293c740d52a9a1c9aa2ace0046db /configure.ac
parente426f5e932cedeb6938469ded340f272390f6a07 (diff)
- (tim) [configure.ac openbsd-compat/bsd-misc.h openbsd-compat/bsd-misc.c] Add
support for platforms missing isblank(). ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 97d4e6bdb..c3700d8dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.457 2010/11/05 07:23:38 dtucker Exp $ 1# $Id: configure.ac,v 1.458 2010/11/08 22:26:23 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.457 $) 18AC_REVISION($Revision: 1.458 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1479,6 +1479,17 @@ AC_CHECK_FUNCS( \
1479 waitpid \ 1479 waitpid \
1480) 1480)
1481 1481
1482AC_LINK_IFELSE(
1483[
1484#include <ctype.h>
1485int main(void)
1486{
1487 return (isblank('a'));
1488}
1489],
1490 [AC_DEFINE(HAVE_ISBLANK, 1, [Define if you have isblank(3C).])
1491])
1492
1482# PKCS#11 support requires dlopen() and co 1493# PKCS#11 support requires dlopen() and co
1483AC_SEARCH_LIBS(dlopen, dl, 1494AC_SEARCH_LIBS(dlopen, dl,
1484 AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support]) 1495 AC_DEFINE([ENABLE_PKCS11], [], [Enable for PKCS#11 support])