summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2003-09-11 14:42:55 +1000
committerDarren Tucker <dtucker@zip.com.au>2003-09-11 14:42:55 +1000
commitc82afd5c8844c2cd5c411124fb077ca15dce6095 (patch)
tree4e45ba1e3f469cc3fd9a223ce01d367f89fc91ee /configure.ac
parent9a959ea1b5d59f8c3de9cb17c10dd2260117f877 (diff)
- (dtucker) [configure.ac] Bug #588, #615: Move other libgen tests to after
the dirname test, to allow a broken dirname to be detected correctly. Based partially on patch supplied by alex.kiernan at thus.net. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index cac1bbf2a..d5d6f546d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.149 2003/09/10 05:22:45 dtucker Exp $ 1# $Id: configure.ac,v 1.150 2003/09/11 04:42:56 dtucker Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -442,7 +442,7 @@ int main(){exit(0);}
442 442
443# Checks for header files. 443# Checks for header files.
444AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \ 444AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
445 getopt.h glob.h ia.h lastlog.h libgen.h limits.h login.h \ 445 getopt.h glob.h ia.h lastlog.h limits.h login.h \
446 login_cap.h maillock.h netdb.h netgroup.h \ 446 login_cap.h maillock.h netdb.h netgroup.h \
447 netinet/in_systm.h paths.h pty.h readpassphrase.h \ 447 netinet/in_systm.h paths.h pty.h readpassphrase.h \
448 rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \ 448 rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \
@@ -463,9 +463,6 @@ if test "x$with_tcp_wrappers" != "xno" ; then
463 fi 463 fi
464fi 464fi
465 465
466AC_CHECK_FUNC(getspnam, ,
467 AC_CHECK_LIB(gen, getspnam, LIBS="$LIBS -lgen"))
468
469AC_ARG_WITH(rpath, 466AC_ARG_WITH(rpath,
470 [ --without-rpath Disable auto-added -R linker paths], 467 [ --without-rpath Disable auto-added -R linker paths],
471 [ 468 [
@@ -676,7 +673,6 @@ AC_CHECK_FUNCS(\
676) 673)
677 674
678AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP)) 675AC_SEARCH_LIBS(nanosleep, rt posix4, AC_DEFINE(HAVE_NANOSLEEP))
679AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
680 676
681dnl Make sure prototypes are defined for these before using them. 677dnl Make sure prototypes are defined for these before using them.
682AC_CHECK_DECL(strsep, [AC_CHECK_FUNCS(strsep)]) 678AC_CHECK_DECL(strsep, [AC_CHECK_FUNCS(strsep)])
@@ -726,6 +722,10 @@ int main(int argc, char **argv) {
726 ]) 722 ])
727]) 723])
728 724
725AC_CHECK_FUNC(getspnam, ,
726 AC_CHECK_LIB(gen, getspnam, LIBS="$LIBS -lgen"))
727AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
728
729dnl Checks for time functions 729dnl Checks for time functions
730AC_CHECK_FUNCS(gettimeofday time) 730AC_CHECK_FUNCS(gettimeofday time)
731dnl Checks for utmp functions 731dnl Checks for utmp functions