summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2005-02-20 21:01:48 +1100
committerDarren Tucker <dtucker@zip.com.au>2005-02-20 21:01:48 +1100
commitd9f88915a2f2e7fe738799122ac288b5b1a13547 (patch)
tree47e36a257610c4944966d52802a4bc247dedcf89 /configure.ac
parent3c774c52f31b54eccb5a936470d21d196968693b (diff)
- (dtucker) [LICENCE Makefile.in README.platform audit-bsm.c configure.ac
defines.h] Bug #125: Add *EXPERIMENTAL* BSM audit support. Configure --with-audit=bsm to enable. Patch originally from Sun Microsystems, parts by John R. Jackson. ok djm@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 38 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fe6b002d4..1bf067a2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.244 2005/02/16 11:49:31 dtucker Exp $ 1# $Id: configure.ac,v 1.245 2005/02/20 10:01:49 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -881,6 +881,37 @@ AC_ARG_WITH(libedit,
881 fi ] 881 fi ]
882) 882)
883 883
884AUDIT_MODULE=none
885AC_ARG_WITH(audit,
886 [ --with-audit=module Enable EXPERIMENTAL audit support (modules=debug,bsm)],
887 [
888 AC_MSG_CHECKING(for supported audit module)
889 case "$withval" in
890 bsm)
891 AC_MSG_RESULT(bsm)
892 AUDIT_MODULE=bsm
893 dnl Checks for headers, libs and functions
894 AC_CHECK_HEADERS(bsm/audit.h, [],
895 [AC_MSG_ERROR(BSM enabled and bsm/audit.h not found)])
896 AC_CHECK_LIB(bsm, getaudit, [],
897 [AC_MSG_ERROR(BSM enabled and required library not found)])
898 AC_CHECK_FUNCS(getaudit, [],
899 [AC_MSG_ERROR(BSM enabled and required function not found)])
900 # These are optional
901 AC_CHECK_FUNCS(getaudit_addr gettext)
902 AC_DEFINE(USE_BSM_AUDIT, [], [Use BSM audit module])
903 ;;
904 debug)
905 AUDIT_MODULE=debug
906 AC_MSG_RESULT(debug)
907 AC_DEFINE(SSH_AUDIT_EVENTS, [], Use audit debugging module)
908 ;;
909 *)
910 AC_MSG_ERROR([Unknown audit module $withval])
911 ;;
912 esac ]
913)
914
884dnl Checks for library functions. Please keep in alphabetical order 915dnl Checks for library functions. Please keep in alphabetical order
885AC_CHECK_FUNCS(\ 916AC_CHECK_FUNCS(\
886 arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \ 917 arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \
@@ -1846,6 +1877,8 @@ TYPE_SOCKLEN_T
1846 1877
1847AC_CHECK_TYPES(sig_atomic_t,,,[#include <signal.h>]) 1878AC_CHECK_TYPES(sig_atomic_t,,,[#include <signal.h>])
1848 1879
1880AC_CHECK_TYPES(in_addr_t,,,[#include <netinet/in.h>])
1881
1849AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [ 1882AC_CACHE_CHECK([for size_t], ac_cv_have_size_t, [
1850 AC_TRY_COMPILE( 1883 AC_TRY_COMPILE(
1851 [ 1884 [
@@ -3195,3 +3228,7 @@ if test ! -z "$NO_PEERCHECK" ; then
3195 echo "" 3228 echo ""
3196fi 3229fi
3197 3230
3231if test "$AUDIT_MODULE" = "bsm" ; then
3232 echo "WARNING: BSM audit support is currently considered EXPERIMENTAL."
3233 echo "See the Solaris section in README.platform for details."
3234fi