summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2011-01-19 23:12:27 +1100
committerDamien Miller <djm@mindrot.org>2011-01-19 23:12:27 +1100
commite323ebc250bb25c51a27be4b34190bf5a371f50b (patch)
tree9bba5aa4e2d1117789511c313935032da3a970a5 /configure.ac
parent15e1b4dea756446a73bcfd9953fc994dea2ed0f6 (diff)
- (djm) [configure.ac] Disable ECC on OpenSSL <0.9.8g. Releases prior to
0.9.8 lacked it, and 0.9.8a through 0.9.8d have proven buggy in pre- release testing (random crashes and failure to load ECC keys). ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 233d3cfa1..208896ed8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.467 2011/01/17 10:15:30 dtucker Exp $ 1# $Id: configure.ac,v 1.468 2011/01/19 12:12:30 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.467 $) 18AC_REVISION($Revision: 1.468 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21# local macros 21# local macros
@@ -2257,8 +2257,14 @@ AC_MSG_CHECKING([whether OpenSSL has complete ECC support])
2257AC_LINK_IFELSE( 2257AC_LINK_IFELSE(
2258 [AC_LANG_SOURCE([[ 2258 [AC_LANG_SOURCE([[
2259#include <openssl/ec.h> 2259#include <openssl/ec.h>
2260#include <openssl/ecdh.h>
2261#include <openssl/ecdsa.h>
2260#include <openssl/evp.h> 2262#include <openssl/evp.h>
2261#include <openssl/objects.h> 2263#include <openssl/objects.h>
2264#include <openssl/opensslv.h>
2265#if OPENSSL_VERSION_NUMBER < 0x0090807f /* 0.9.8g */
2266# error "OpenSSL < 0.9.8g has unreliable ECC code"
2267#endif
2262int main(void) { 2268int main(void) {
2263 EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp521r1); 2269 EC_KEY *e = EC_KEY_new_by_curve_name(NID_secp521r1);
2264 const EVP_MD *m = EVP_sha512(); /* We need this too */ 2270 const EVP_MD *m = EVP_sha512(); /* We need this too */