summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2013-03-08 12:14:22 +1100
committerDamien Miller <djm@mindrot.org>2013-03-08 12:14:22 +1100
commite4f43478228256ddbbce3b7f0c312ff5c707b667 (patch)
tree5703916e54430cc878cdbae9aab558c1520c8f1c /configure.ac
parent2b6ea47106537cff31c863d05062ac97efe3f132 (diff)
- (djm) [configure.ac] Add a timeout to the select/rlimit test to give it a
chance to complete on broken systems; ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ccf3373bd..6005d7c2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.512 2013/03/06 06:48:48 dtucker Exp $ 1# $Id: configure.ac,v 1.513 2013/03/08 01:14:23 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.512 $) 18AC_REVISION($Revision: 1.513 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2673,6 +2673,7 @@ AC_RUN_IFELSE(
2673 struct rlimit rl_zero; 2673 struct rlimit rl_zero;
2674 int fd, r; 2674 int fd, r;
2675 fd_set fds; 2675 fd_set fds;
2676 struct timeval tv;
2676 2677
2677 fd = open("/dev/null", O_RDONLY); 2678 fd = open("/dev/null", O_RDONLY);
2678 FD_ZERO(&fds); 2679 FD_ZERO(&fds);
@@ -2680,7 +2681,9 @@ AC_RUN_IFELSE(
2680 rl_zero.rlim_cur = rl_zero.rlim_max = 0; 2681 rl_zero.rlim_cur = rl_zero.rlim_max = 0;
2681 setrlimit(RLIMIT_FSIZE, &rl_zero); 2682 setrlimit(RLIMIT_FSIZE, &rl_zero);
2682 setrlimit(RLIMIT_NOFILE, &rl_zero); 2683 setrlimit(RLIMIT_NOFILE, &rl_zero);
2683 r = select(fd+1, &fds, NULL, NULL, NULL); 2684 tv.tv_sec = 1;
2685 tv.tv_usec = 0;
2686 r = select(fd+1, &fds, NULL, NULL, &tv);
2684 exit (r == -1 ? 1 : 0); 2687 exit (r == -1 ? 1 : 0);
2685 ]])], 2688 ]])],
2686 [AC_MSG_RESULT([yes]) 2689 [AC_MSG_RESULT([yes])