summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2003-01-07 15:18:32 +1100
committerDamien Miller <djm@mindrot.org>2003-01-07 15:18:32 +1100
commite832819cf7289b467070fc31c5080c133f0a101e (patch)
tree5c0cfb811b429cd71c551dda025442f16ccd7114 /configure.ac
parent48cb8aa935211ff95ff62267a799d3548df442d4 (diff)
- (djm) Bug #26: Use local mkstemp() rather than glibc's silly one. Fixes
Can't pass KRB4 TGT passing. Fix from: jan.iven@cern.ch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e96a0721d..f01c0c642 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.93 2002/11/22 21:29:03 tim Exp $ 1# $Id: configure.ac,v 1.94 2003/01/07 04:18:33 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -680,6 +680,32 @@ int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
680 ) 680 )
681fi 681fi
682 682
683dnl see whether mkstemp() requires XXXXXX
684if test "x$ac_cv_func_mkdtemp" = "xyes" ; then
685AC_MSG_CHECKING([for (overly) strict mkstemp])
686AC_TRY_RUN(
687 [
688#include <stdlib.h>
689main() { char template[]="conftest.mkstemp-test";
690if (mkstemp(template) == -1)
691 exit(1);
692unlink(template); exit(0);
693}
694 ],
695 [
696 AC_MSG_RESULT(no)
697 ],
698 [
699 AC_MSG_RESULT(yes)
700 AC_DEFINE(HAVE_STRICT_MKSTEMP)
701 ],
702 [
703 AC_MSG_RESULT(yes)
704 AC_DEFINE(HAVE_STRICT_MKSTEMP)
705 ]
706)
707fi
708
683AC_FUNC_GETPGRP 709AC_FUNC_GETPGRP
684 710
685# Check for PAM libs 711# Check for PAM libs