summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2004-01-02 18:01:30 +1100
committerDamien Miller <djm@mindrot.org>2004-01-02 18:01:30 +1100
commit0f47c53742a31b9682c05660dd8de1e860fb1fc5 (patch)
tree7ca6b79f339d5de9bd0ab6d7fe859b64dc0a5ab6 /configure.ac
parentc8ec16651ea05e160f5dd51dc70f0db946ee2761 (diff)
- (djm) OSX/Darwin put the PAM headers in a different place, detect this.
Report from jakob@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index dc81dafe1..9127489de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.181 2004/01/02 06:53:04 djm Exp $ 1# $Id: configure.ac,v 1.182 2004/01/02 07:01:31 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -499,7 +499,7 @@ int main(){exit(0);}
499AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \ 499AC_CHECK_HEADERS(bstring.h crypt.h endian.h features.h floatingpoint.h \
500 getopt.h glob.h ia.h lastlog.h limits.h login.h \ 500 getopt.h glob.h ia.h lastlog.h limits.h login.h \
501 login_cap.h maillock.h netdb.h netgroup.h \ 501 login_cap.h maillock.h netdb.h netgroup.h \
502 netinet/in_systm.h paths.h pty.h readpassphrase.h \ 502 netinet/in_systm.h pam/pam_appl.h paths.h pty.h readpassphrase.h \
503 rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \ 503 rpc/types.h security/pam_appl.h shadow.h stddef.h stdint.h \
504 strings.h sys/strtio.h sys/audit.h sys/bitypes.h sys/bsdtty.h \ 504 strings.h sys/strtio.h sys/audit.h sys/bitypes.h sys/bsdtty.h \
505 sys/cdefs.h sys/mman.h sys/pstat.h sys/select.h sys/stat.h \ 505 sys/cdefs.h sys/mman.h sys/pstat.h sys/select.h sys/stat.h \
@@ -929,7 +929,8 @@ AC_ARG_WITH(pam,
929 [ --with-pam Enable PAM support ], 929 [ --with-pam Enable PAM support ],
930 [ 930 [
931 if test "x$withval" != "xno" ; then 931 if test "x$withval" != "xno" ; then
932 if test "x$ac_cv_header_security_pam_appl_h" != "xyes" ; then 932 if test "x$ac_cv_header_security_pam_appl_h" != "xyes" && \
933 test "x$ac_cv_header_pam_pam_appl_h" != "xyes" ; then
933 AC_MSG_ERROR([PAM headers not found]) 934 AC_MSG_ERROR([PAM headers not found])
934 fi 935 fi
935 936
@@ -958,7 +959,11 @@ if test "x$PAM_MSG" = "xyes" ; then
958 AC_TRY_COMPILE( 959 AC_TRY_COMPILE(
959 [ 960 [
960#include <stdlib.h> 961#include <stdlib.h>
962#if defined(HAVE_SECURITY_PAM_APPL_H)
961#include <security/pam_appl.h> 963#include <security/pam_appl.h>
964#elif defined (HAVE_PAM_PAM_APPL_H)
965#include <pam/pam_appl.h>
966#endif
962 ], 967 ],
963 [(void)pam_strerror((pam_handle_t *)NULL, -1);], 968 [(void)pam_strerror((pam_handle_t *)NULL, -1);],
964 [AC_MSG_RESULT(no)], 969 [AC_MSG_RESULT(no)],