summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2007-03-21 21:39:57 +1100
committerDarren Tucker <dtucker@zip.com.au>2007-03-21 21:39:57 +1100
commit164aa30e4604672f688b5c51b90e42dfa129821b (patch)
tree4ce05465abbf23eb557d9f9ef4841a6be23c2365 /configure.ac
parent04354b97dc1cc87d01a33db508a9ea0f0148fb83 (diff)
- (dtucker) [configure.ac openbsd-compat/bsd-getpeereid.c] Bug #1287: Use
getpeerucred to implement getpeereid (currently only Solaris 10 and up). Patch by Jan.Pechanec at Sun.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index a2b236355..f155ada60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.372 2007/03/05 00:51:27 djm Exp $ 1# $Id: configure.ac,v 1.373 2007/03/21 10:39:57 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.372 $) 18AC_REVISION($Revision: 1.373 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -1241,6 +1241,7 @@ AC_CHECK_FUNCS( \
1241 getnameinfo \ 1241 getnameinfo \
1242 getopt \ 1242 getopt \
1243 getpeereid \ 1243 getpeereid \
1244 getpeerucred \
1244 _getpty \ 1245 _getpty \
1245 getrlimit \ 1246 getrlimit \
1246 getttyent \ 1247 getttyent \
@@ -1489,7 +1490,7 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <stdio.h>
1489 1490
1490# Check for missing getpeereid (or equiv) support 1491# Check for missing getpeereid (or equiv) support
1491NO_PEERCHECK="" 1492NO_PEERCHECK=""
1492if test "x$ac_cv_func_getpeereid" != "xyes" ; then 1493if test "x$ac_cv_func_getpeereid" != "xyes" -a "x$ac_cv_func_getpeerucred" != "xyes"; then
1493 AC_MSG_CHECKING([whether system supports SO_PEERCRED getsockopt]) 1494 AC_MSG_CHECKING([whether system supports SO_PEERCRED getsockopt])
1494 AC_TRY_COMPILE( 1495 AC_TRY_COMPILE(
1495 [#include <sys/types.h> 1496 [#include <sys/types.h>
@@ -4030,12 +4031,12 @@ if test ! -z "$RAND_HELPER_CMDHASH" ; then
4030fi 4031fi
4031 4032
4032if test ! -z "$NO_PEERCHECK" ; then 4033if test ! -z "$NO_PEERCHECK" ; then
4033 echo "WARNING: the operating system that you are using does not " 4034 echo "WARNING: the operating system that you are using does not"
4034 echo "appear to support either the getpeereid() API nor the " 4035 echo "appear to support getpeereid(), getpeerucred() or the"
4035 echo "SO_PEERCRED getsockopt() option. These facilities are used to " 4036 echo "SO_PEERCRED getsockopt() option. These facilities are used to"
4036 echo "enforce security checks to prevent unauthorised connections to " 4037 echo "enforce security checks to prevent unauthorised connections to"
4037 echo "ssh-agent. Their absence increases the risk that a malicious " 4038 echo "ssh-agent. Their absence increases the risk that a malicious"
4038 echo "user can connect to your agent. " 4039 echo "user can connect to your agent."
4039 echo "" 4040 echo ""
4040fi 4041fi
4041 4042