summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Miller <djm@mindrot.org>2006-08-31 03:24:41 +1000
committerDamien Miller <djm@mindrot.org>2006-08-31 03:24:41 +1000
commit1b06dc30ad4692ec76c476d130ba7366f7ebfef2 (patch)
tree85a3f1df0e15d7da1939df14a43a35dc4380a001 /configure.ac
parent26d4e19caa3013f57dc3c1462847eceaac6a1d7d (diff)
- (djm) [CREDITS LICENCE Makefile.in auth.c configure.ac includes.h ]
[platform.c platform.h sshd.c openbsd-compat/Makefile.in] [openbsd-compat/openbsd-compat.h openbsd-compat/port-solaris.c] [openbsd-compat/port-solaris.h] Add support for Solaris process contracts, enabled with --use-solaris-contracts. Patch from Chad Mynhier, tweaked by dtucker@ and myself; ok dtucker@
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 90cfbea9a..3aba414a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.355 2006/08/20 11:43:19 dtucker Exp $ 1# $Id: configure.ac,v 1.356 2006/08/30 17:24:41 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.355 $) 18AC_REVISION($Revision: 1.356 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -127,6 +127,10 @@ AC_ARG_WITH(rpath,
127 ] 127 ]
128) 128)
129 129
130# Messages for features tested for in target-specific section
131SIA_MSG="no"
132SPC_MSG="no"
133
130# Check for some target-specific stuff 134# Check for some target-specific stuff
131case "$host" in 135case "$host" in
132*-*-aix*) 136*-*-aix*)
@@ -438,6 +442,17 @@ mips-sony-bsd|mips-sony-newsos4)
438 else 442 else
439 AC_MSG_RESULT(no) 443 AC_MSG_RESULT(no)
440 fi 444 fi
445 AC_ARG_WITH(solaris-contracts,
446 [ --with-solaris-contracts Enable Solaris process contracts (experimental)],
447 [
448 AC_CHECK_LIB(contract, ct_tmpl_activate,
449 [ AC_DEFINE(USE_SOLARIS_PROCESS_CONTRACTS, 1,
450 [Define if you have Solaris process contracts])
451 SSHDLIBS="$SSHDLIBS -lcontract"
452 AC_SUBST(SSHDLIBS)
453 SPC_MSG="yes" ], )
454 ],
455 )
441 ;; 456 ;;
442*-*-sunos4*) 457*-*-sunos4*)
443 CPPFLAGS="$CPPFLAGS -DSUNOS4" 458 CPPFLAGS="$CPPFLAGS -DSUNOS4"
@@ -586,6 +601,7 @@ mips-sony-bsd|mips-sony-newsos4)
586 system's login() call]) 601 system's login() call])
587 AC_DEFINE(DISABLE_FD_PASSING) 602 AC_DEFINE(DISABLE_FD_PASSING)
588 LIBS="$LIBS -lsecurity -ldb -lm -laud" 603 LIBS="$LIBS -lsecurity -ldb -lm -laud"
604 SIA_MSG="yes"
589 else 605 else
590 AC_MSG_RESULT(no) 606 AC_MSG_RESULT(no)
591 AC_DEFINE(LOCKED_PASSWD_SUBSTR, "Nologin", 607 AC_DEFINE(LOCKED_PASSWD_SUBSTR, "Nologin",
@@ -3905,6 +3921,7 @@ echo " sshd superuser user PATH: $J"
3905fi 3921fi
3906echo " Manpage format: $MANTYPE" 3922echo " Manpage format: $MANTYPE"
3907echo " PAM support: $PAM_MSG" 3923echo " PAM support: $PAM_MSG"
3924echo " OSF SIA support: $SIA_MSG"
3908echo " KerberosV support: $KRB5_MSG" 3925echo " KerberosV support: $KRB5_MSG"
3909echo " SELinux support: $SELINUX_MSG" 3926echo " SELinux support: $SELINUX_MSG"
3910echo " Smartcard support: $SCARD_MSG" 3927echo " Smartcard support: $SCARD_MSG"
@@ -3912,6 +3929,7 @@ echo " S/KEY support: $SKEY_MSG"
3912echo " TCP Wrappers support: $TCPW_MSG" 3929echo " TCP Wrappers support: $TCPW_MSG"
3913echo " MD5 password support: $MD5_MSG" 3930echo " MD5 password support: $MD5_MSG"
3914echo " libedit support: $LIBEDIT_MSG" 3931echo " libedit support: $LIBEDIT_MSG"
3932echo " Solaris process contract support: $SPC_MSG"
3915echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 3933echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
3916echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 3934echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
3917echo " BSD Auth support: $BSD_AUTH_MSG" 3935echo " BSD Auth support: $BSD_AUTH_MSG"