summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarren Tucker <dtucker@zip.com.au>2005-02-11 16:11:49 +1100
committerDarren Tucker <dtucker@zip.com.au>2005-02-11 16:11:49 +1100
commit1b6f2291e4adf4d3e7e81d35194b1ad7751270f2 (patch)
tree88f1d88f829503d2db8ab1c9c13ddfe33688e157 /configure.ac
parent2f9573df714b221acbf92f8b48645849475136fa (diff)
- (dtucker) [configure.ac] Tidy up configure --help output.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9d1d33282..2df8a5e87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.240 2005/02/10 11:28:55 dtucker Exp $ 1# $Id: configure.ac,v 1.241 2005/02/11 05:11:49 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -766,8 +766,7 @@ fi
766# Check whether user wants S/Key support 766# Check whether user wants S/Key support
767SKEY_MSG="no" 767SKEY_MSG="no"
768AC_ARG_WITH(skey, 768AC_ARG_WITH(skey,
769 [ --with-skey[[=PATH]] Enable S/Key support 769 [ --with-skey[[=PATH]] Enable S/Key support (optionally in PATH)],
770 (optionally in PATH)],
771 [ 770 [
772 if test "x$withval" != "xno" ; then 771 if test "x$withval" != "xno" ; then
773 772
@@ -808,8 +807,7 @@ int main() { char *ff = skey_keyinfo(""); ff=""; exit(0); }
808# Check whether user wants TCP wrappers support 807# Check whether user wants TCP wrappers support
809TCPW_MSG="no" 808TCPW_MSG="no"
810AC_ARG_WITH(tcp-wrappers, 809AC_ARG_WITH(tcp-wrappers,
811 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support 810 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
812 (optionally in PATH)],
813 [ 811 [
814 if test "x$withval" != "xno" ; then 812 if test "x$withval" != "xno" ; then
815 saved_LIBS="$LIBS" 813 saved_LIBS="$LIBS"
@@ -865,7 +863,7 @@ AC_ARG_WITH(tcp-wrappers,
865# Check whether user wants libedit support 863# Check whether user wants libedit support
866LIBEDIT_MSG="no" 864LIBEDIT_MSG="no"
867AC_ARG_WITH(libedit, 865AC_ARG_WITH(libedit,
868 [ --with-libedit[[=PATH]] Enable libedit support for sftp], 866 [ --with-libedit[[=PATH]] Enable libedit support for sftp],
869 [ if test "x$withval" != "xno" ; then 867 [ if test "x$withval" != "xno" ; then
870 AC_CHECK_LIB(edit, el_init, 868 AC_CHECK_LIB(edit, el_init,
871 [ AC_DEFINE(USE_LIBEDIT, [], [Use libedit for sftp]) 869 [ AC_DEFINE(USE_LIBEDIT, [], [Use libedit for sftp])
@@ -2583,7 +2581,7 @@ fi
2583 2581
2584# check for /etc/default/login and use it if present. 2582# check for /etc/default/login and use it if present.
2585AC_ARG_ENABLE(etc-default-login, 2583AC_ARG_ENABLE(etc-default-login,
2586 [ --disable-etc-default-login Disable using PATH from /etc/default/login [no]], 2584 [ --disable-etc-default-login Disable using PATH from /etc/default/login [no]],
2587 [ if test "x$enableval" = "xno"; then 2585 [ if test "x$enableval" = "xno"; then
2588 AC_MSG_NOTICE([/etc/default/login handling disabled]) 2586 AC_MSG_NOTICE([/etc/default/login handling disabled])
2589 etc_default_login=no 2587 etc_default_login=no