summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rice <tim@multitalents.net>2002-04-17 21:19:14 -0700
committerTim Rice <tim@multitalents.net>2002-04-17 21:19:14 -0700
commit43a1c13e0fd522cf31666931b66891d23bb3de6d (patch)
treed4b3683b964066dcd5cbce94c304c60217ebd7e6 /configure.ac
parent5efd71038d4207b576caea3ce148a8cffe268eae (diff)
[configure.ac] Issue warning on --with-default-path=/some_path
if LOGIN_CAP is enabled. Report & testing by Tuc <tuc@ttsg.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 23 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index d9ca33d69..6b2dfe212 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.45 2002/04/16 04:10:11 tim Exp $ 1# $Id: configure.ac,v 1.46 2002/04/18 04:19:15 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -2019,17 +2019,28 @@ else
2019 ) 2019 )
2020fi 2020fi
2021 2021
2022dnl BSD systems use /etc/login.conf so --with-default-path= has no effect
2023if test $ac_cv_func_login_getcapbool = "yes" -a \
2024 $ac_cv_header_login_cap_h = "yes" ; then
2025 USES_LOGIN_CONF=yes
2026fi
2022# Whether to mess with the default path 2027# Whether to mess with the default path
2023SERVER_PATH_MSG="(default)" 2028SERVER_PATH_MSG="(default)"
2024AC_ARG_WITH(default-path, 2029AC_ARG_WITH(default-path,
2025 [ --with-default-path=PATH Specify default \$PATH environment for server], 2030 [ --with-default-path=PATH Specify default \$PATH environment for server],
2026 [ 2031 [
2027 if test "x$withval" != "xno" ; then 2032 if test "$USES_LOGIN_CONF" = "yes" ; then
2033 AC_MSG_WARN([
2034--with-default-path=PATH has no effect on this system.
2035Edit /etc/login.conf instead.])
2036 elif test "x$withval" != "xno" ; then
2028 user_path="$withval" 2037 user_path="$withval"
2029 SERVER_PATH_MSG="$withval" 2038 SERVER_PATH_MSG="$withval"
2030 fi 2039 fi
2031 ], 2040 ],
2032 [ 2041 [ if test "$USES_LOGIN_CONF" = "yes" ; then
2042 AC_MSG_WARN([Make sure the path to scp is in /etc/login.conf])
2043 else
2033 AC_TRY_RUN( 2044 AC_TRY_RUN(
2034 [ 2045 [
2035/* find out what STDPATH is */ 2046/* find out what STDPATH is */
@@ -2079,10 +2090,12 @@ main()
2079 AC_MSG_RESULT(Adding $t_bindir to USER_PATH so scp will work) 2090 AC_MSG_RESULT(Adding $t_bindir to USER_PATH so scp will work)
2080 fi 2091 fi
2081 fi 2092 fi
2082 ] 2093 fi ]
2083) 2094)
2084AC_DEFINE_UNQUOTED(USER_PATH, "$user_path") 2095if test "$USES_LOGIN_CONF" != "yes" ; then
2085AC_SUBST(user_path) 2096 AC_DEFINE_UNQUOTED(USER_PATH, "$user_path")
2097 AC_SUBST(user_path)
2098fi
2086 2099
2087# Whether to force IPv4 by default (needed on broken glibc Linux) 2100# Whether to force IPv4 by default (needed on broken glibc Linux)
2088IPV4_HACK_MSG="no" 2101IPV4_HACK_MSG="no"
@@ -2433,7 +2446,11 @@ echo " Configuration files: $D"
2433echo " Askpass program: $E" 2446echo " Askpass program: $E"
2434echo " Manual pages: $F" 2447echo " Manual pages: $F"
2435echo " PID file: $G" 2448echo " PID file: $G"
2449if test "$USES_LOGIN_CONF" = "yes" ; then
2450echo " At runtime, sshd will use the path defined in /etc/login.conf"
2451else
2436echo " sshd default user PATH: $H" 2452echo " sshd default user PATH: $H"
2453fi
2437echo " Manpage format: $MANTYPE" 2454echo " Manpage format: $MANTYPE"
2438echo " PAM support: ${PAM_MSG}" 2455echo " PAM support: ${PAM_MSG}"
2439echo " KerberosIV support: $KRB4_MSG" 2456echo " KerberosIV support: $KRB4_MSG"